Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The IRQ for a device appears as a negative number in Device Manager on a computer that is running Windows Vista or Windows Server 2008


View products that this article applies to.

Symptoms

On a computer that is running Windows Vista or Windows Server 2008, you view resources by type in Device Manager. When you expand Interrupt request, the interrupt request (IRQ) for one or more of the devices that are listed may appear as a negative number.

For more information about how to see the devices that are listed under Interrupt request in Device Manager, see the "More Information" section.

↑ Back to the top


Cause

This issue can occur if a device uses Message Signaled Interrupts (MSI).

↑ Back to the top


More information

MSI is supported in the PCI Local Bus Specification, Revision 2.2 standard and in later versions. MSI is the native interrupt mechanism for devices that are connected to a PCI Express bus or to a PCI-X bus. MSI requires Advanced Programmable Interrupt Controllers (APICs).

To see the devices that are listed under Interrupt request in Device Manager, follow these steps:
  1. Start Device Manager.
  2. Click View, and then click Resources by type.
  3. Expand Interrupt request.

↑ Back to the top


References

For more information about MSI, visit the following Microsoft Web site: For more information about APICs, visit the following Microsoft Web site:

↑ Back to the top


Keywords: kbhardware, kbtshoot, kbprb, KB940394

↑ Back to the top

Article Info
Article ID : 940394
Revision : 6
Created on : 8/4/2007
Published on : 8/4/2007
Exists online : False
Views : 379