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A URL that includes a "notes:" prefix does not work in Outlook Web Access for Exchange 2003


View products that this article applies to.

Symptoms

You use Microsoft Office Outlook Web Access for Microsoft Exchange Server 2003 to access an e-mail message that includes a Lotus Notes URL. The Lotus Notes URL resembles the following:
<HTML>
Here is a link: <A HREF="notes://servername">notes://servername</A>
</HTML>
In this situation, the URL in the <A HREF> tag is removed. Therefore, the URL does not work in Outlook Web Access.

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Cause

The Safe HTML filtering feature in Outlook Web Access will remove any unsafe protocol links. This behavior occurs because a malicious HTML e-mail message can contain unsafe protocol URL links. Outlook Web Access for Exchange 2003 recognizes only the following URL prefixes as safe:
  • http:
  • https:
  • ftp:
  • file:
  • mailto:
  • news:
  • gopher:
  • about:
  • wais:
  • cid:
  • mhtml:
  • ipp:
  • msdaipp:

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Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply this hotfix, you must create the AdditionalSafeURLScheme registry entry. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK
  2. Click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\InternetContent
  3. On the Edit menu, point to New, and then click String Value.
  4. In the details pane, type AdditionalSafeURLScheme, and then press ENTER.
  5. Right-click the AdditionalSafeURLScheme registry entry, and then click Modify.
  6. In the Value data box, type NOTES, and then click OK.

    NoteYou can add other URL prefixes as necessary by using a space or semi-colon separated list.
  7. Exit Registry Editor.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Microsoft Exchange Server 2003 Service Pack 2 (SP2) must be installed on the server before you apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services are automatically restarted when you apply this hotfix:
  • Microsoft Exchange Information Store service
  • Microsoft Search service
  • IIS Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Davex.dll6.5.7653.91,131,52009-Jul-200718:29
Exoledb.dll6.5.7653.92,620,92809-Jul-200703:29
Exosal.dll6.5.7653.970,14409-Jul-200718:13
Mdbmsg.dll6.5.7653.93,378,68809-Jul-200716:53
Store.exe6.5.7653.95,265,40809-Jul-200718:16

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
920781 Lotus Notes DocLinks in e-mail messages are replaced with bitmap icons in Exchange 2003

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Keywords: KB939999, kbqfe, kbhotfixserver, kbexpertiseinter, kbexchowa, kbautohotfix

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Article Info
Article ID : 939999
Revision : 2
Created on : 9/10/2008
Published on : 9/10/2008
Exists online : False
Views : 217