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FIX: Error message when you try to generate a schema for an adapter in BizTalk Server 2006: "Error reading WSDL file.[System.InvalidOperationException] There is an error in XML document (190, 41).[System.Xml.XmlException]"


View products that this article applies to.

Symptoms

In Microsoft BizTalk Server 2006, you try to generate a schema at design time for one of the following adapters:
  • Microsoft BizTalk Adapter for J.D. Edwards EnterpriseOne
  • Microsoft BizTalk Adapter for J.D. Edwards OneWorld
  • Microsoft BizTalk Adapter for Siebel eBusiness Applications
When you do this, the schema generation fails. When this problem occurs, you receive the following error messages:
Error message 1
----------------------------------------------------------
Microsoft.BizTalk.Adapter.Framework.CannotProceedException
----------------------------------------------------------
Error reading WSDL file.[System.InvalidOperationException] There is an error in XML document (190, 41).[System.Xml.XmlException]
Name cannot begin with the '=' character, hexadecimal value 0x3D. Line 190, position 41.
---
OK
---
Error message 2
-------------------------------------------
System.Runtime.InteropServices.COMException
-------------------------------------------
An error occurred during wizard execution.Cannot find file "C:\Lab\BizTalk Orchestration_1.odx".
---
OK
---

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Cause

This problem occurs because some XML characters are not allowed as a part of a field name for the schema or as a part of an element name for the schema in BizTalk Server 2006. For example, the following XML characters are not allowed:
  • =
  • >=
  • <=
  • ><
  • >
  • <
  • "
  • [
  • &
  • ]
  • (
  • '
  • *
  • ?

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 installed to apply this hotfix.

Restart information

You do not have to restart the computer after you apply this hotfix.

Registry information

You do not have to change the registry.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain all the files that you must have to fully update a product to the latest build.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Btcore.dll1.0.1095.02,131,80012-Mar-200722:39
Xmlosa.dll1.0.1095.0725,84812-Mar-200722:39
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

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Workaround

To work around this problem, change the field name for the schema or the element name for the schema on the server. Change the name so that the name no longer contains these XML characters.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbfix, kbpubtypekc, kbqfe, kbexpertiseadvanced, kbhotfixserver, KB939920

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Article Info
Article ID : 939920
Revision : 4
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 419