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After you append some characters in an HTML page text box in Internet Explorer 7, the original characters in the text box are replaced with the newly typed characters


View products that this article applies to.

Symptoms

Consider the following scenario on a Windows Vista-based, a Windows XP-based, or a Windows Server 2003-based computer that is running Windows Internet Explorer 7:
  • In Internet Explorer 7, you open an HTML page that contains a text box.
  • In the text box, you use the Japanese Input Method Editor (IME) to type some characters. Additionally, after you type the characters, you do not press ENTER for confirmation.
  • You click anywhere out of the text box.

    Note When you click anywhere out of the text box, the OnChange event occurs.
  • In the text box, you type to append some new characters.
  • You click anywhere out of the text box again.
In this scenario, the original characters in the text box are replaced with the characters that you append.

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Cause

This problem occurs because the OnChange event is fired before IME composition is stopped. Therefore, IME receives incorrect information about the text range. This incorrect text range information causes IME to remove the original characters in the text box.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

Windows Vista

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To use one of the hotfixes in this package, you have to make some changes to the registry. For more information, see the "How to enable this hotfix" section.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll7.0.6000.206363,583,48810-Jul-200702:24x86
Mshtml.tlb7.0.6000.206361,383,42409-Jul-200723:46Not Applicable

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed.
Restart requirement
You have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To use one of the hotfixes in this package, you have to make some changes to the registry. For more information, see the "How to enable this hotfix" section.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll7.0.6000.206363,583,48812-Jul-200713:29x86

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows Server 2003 Service Pack 2 (SP2) installed.
Restart requirement
You have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To use one of the hotfixes in this package, you have to make some changes to the registry. For more information, see the "How to enable this hotfix" section.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll7.0.6000.206363,583,48814-Jul-200706:18x86

How to enable this hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable this hotfix, follow these steps, as appropriate for your situation.

Windows Vista

  1. Click Start
    , type regedit in the Start Search box, and then click regedit in the Programs list.
    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  2. Locate the following registry subkey, and then click it:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type the following key name, and then press ENTER:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type iexplore.exe, and then press ENTER.
  7. On the Edit menu, click Modify.
  8. Type 1, and then click OK.
  9. Exit Registry Editor.

Windows XP and Windows Server 2003

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey, and then click it:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. On the Edit menu, point to New, and then click Key.
  4. Type the following key name, and then press ENTER:
    FEATURE_IME_KEEP_TEXT_AFTER_ONCHANGE_KB939913
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type iexplore.exe, and then press ENTER.
  7. On the Edit menu, click Modify.
  8. Type 1, and then click OK.
  9. Exit Registry Editor.

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Workaround

To work around this problem, use the OnBlur event instead of the OnChange event.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbvistasp1fix, kbexpertisebeginner, kbexpertiseadvanced, kbfix, kbqfe, kbHotfixServer, kbautohotfix, KB939913

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Article Info
Article ID : 939913
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 336