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A GDI handle leak occurs in Windows XP and in Windows Server 2003 when an application frequently calls the CreateRectRgn function


View products that this article applies to.

Symptoms

In Microsoft Windows XP and in Microsoft Windows Server 2003, a graphics device interface (GDI) handle leak occurs when an application frequently calls the CreateRectRgn function. When this problem occurs, you may experience the following symptoms:
  • The count of GDI handles continually increases.
  • The application becomes unstable.
  • The application does not work correctly if the GDI handle count reaches the quota for each process.

    Note By default, the quota for each process is 10,000.
This problem occurs if the following conditions are true:
  • The application is multithreaded.
  • The computer uses multiple processors. Or, hyper-threading is enabled.
Note This problem does not occur in Windows Vista.

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Cause

This problem occurs because of a race condition in the GDI module. The GDI module incorrectly manages the REGION object handles.

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Resolution

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Win32k.sys5.1.2600.31801,843,96818-Jul-200711:12x86

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Gdi32.dll5.2.3790.4033282,62402-Mar-200706:41x86SP2
Win32k.sys5.2.3790.41111,846,27204-Jul-200713:57x86SP2
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.4033619,52004-Jul-200702:52x64SP2Not applicable
Win32k.sys5.2.3790.41114,536,32004-Jul-200702:52x64SP2Not applicable
Wgdi32.dll5.2.3790.4033290,81604-Jul-200702:52x86SP2WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.4033913,40804-Jul-200702:53IA-64SP2Not applicable
Win32k.sys5.2.3790.41115,559,29604-Jul-200702:53IA-64SP2Not applicable
Wgdi32.dll5.2.3790.4033290,81604-Jul-200702:53x86SP2WOW
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Gdi32.dll5.2.3790.2892284,16002-Mar-200708:11x86SP1
Win32k.sys5.2.3790.29671,856,00004-Jul-200712:45x86SP1
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2892617,47204-Jul-200702:48x64SP1Not applicable
Win32k.sys5.2.3790.29674,542,97604-Jul-200702:48x64SP1Not applicable
Wgdi32.dll5.2.3790.2892287,74404-Jul-200702:48x86SP1WOW
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2892909,31204-Jul-200702:48IA-64SP1Not applicable
Win32k.sys5.2.3790.29675,554,68804-Jul-200702:48IA-64SP1Not applicable
Wgdi32.dll5.2.3790.2892287,74404-Jul-200702:48x86SP1WOW

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Workaround

To work around this problem, restart the application that has this problem. Or, use a single-processor computer and disable hyper-threading.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinxppresp3fix, kbwinserv2003postsp2fix, kbexpertiseinter, kbbug, kbfix, kbHotfixServer, kbqfe, KB939884

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Article Info
Article ID : 939884
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 290