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Error message when an NFS client accesses a file on an NFS share in Windows Storage Server 2003, in Windows Server 2003 R2, or in Windows Services for UNIX 3.5: "Stop 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)"


View products that this article applies to.

Symptoms

A computer that is running Microsoft Windows Storage Server 2003, Windows Server 2003 R2, or Microsoft Windows Services for UNIX 3.5 may randomly stop responding. Additionally, you receive the following Stop error message:
Stop 0x0000007E (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED)
You may experience this problem when the following conditions are both true:
  • A Network File System (NFS) client computer is used to access a file.
  • The file has the SYSTEM attribute set by using NFS.
The Stop error is more likely to occur in the following scenario:
  • The NFS client computer modifies the file attributes of a file.
    For example, the NFS client computer modifies the owner attribute or the group attribute.
  • This file has had the SYSTEM attribute set.
  • The SYSTEM attribute was set by using Windows Storage Server or by using Windows Services for UNIX.

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Cause

This problem occurs because of a problem in Server for NFS. When the following conditions are true, Server for NFS does not correctly detect asynchronous I/O completion operations for metadata read operations:
  • There is a handle for a file in the Server for NFS handle cache.
  • The handle in the Server for NFS handle cache was opened for asynchronous I/O because of an earlier request to Server for NFS.
  • The metadata for the file is not present in the Windows file system cache.
Under these conditions, Server for NFS does not detect the asynchronous I/O completions for the metadata read operation when Server for NFS tries to retrieve the file attribute metadata.

Therefore, Server for NFS continues without waiting for the I/O operation to finish. Some time later, the file system finishes the I/O operation. Then, the file system writes the I/O completion status to a location on the CPU stack that existed when the I/O operation started. If the stack location has been reused, memory corruption might occur. Therefore, the computer may stop responding.

Note The SYSTEM file attribute is not directly related to the problem that is described in this article. However, if this attribute is set, a timing issue is more likely to occur. This timing issue affects the way that the NTFS file system changes the way that the I/O operation finishes. Because the problem that is mentioned in this article is related to a timing issue, a change in the behavior of NTFS could affect the way that the Server for NFS problem affects the computer.

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Resolution

Hotfix information

Hotfix installation information

  • The "Server for NFS" component is now part of the Windows Server 2003 R2 operating system. Installing Services for UNIX 3.5 on a Windows Server 2003 R2-based system to get NFS functionality is no longer required. It is now an optional Windows component and can be added to an R2 system by using the Add/Remove Windows Components Wizard.
  • The storage server package can only be installed in Windows Storage Server 2003.
  • The Services for UNIX 3.5 package can be installed on any Windows 2000-based, Windows XP-based, Windows Server 2003-based computer that is running Server for NFS service from Services for UNIX 3.5 software. However, the package may not be installed on a Windows Server 2003 R2-based computer.

Windows Server 2003 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, your computer must be running Windows Server 2003 R2 with Service Pack 1 (SP1) or Windows Server 2003 R2 with Service Pack 2 (SP2) and Microsoft Services for NFS.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace a previously released hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Storage Server 2003 R2 with Service Pack 1, x86 edition
File nameFile versionFile sizeDateTimePlatformSP requirement
Nfssvr.sys5.2.3790.3038467,45601-Nov-200711:55x86SP1
Windows Storage Server 2003 with SP2, x86 edition
File nameFile versionFile sizeDateTimePlatformSP requirement
Nfssvr.sys5.2.3790.4182467,45602-Nov-200715:32x86SP2
Windows Storage Server 2003 with SP1, x64 edition
File nameFile versionFile sizeDateTimePlatformSP requirement
Nfssvr.sys5.2.3790.3038813,56805-Nov-200702:35x64SP1
Windows Storage Server 2003 R2 with SP2, x64 edition
File nameFile versionFile sizeDateTimePlatformSP requirement
Nfssvr.sys5.2.3790.4182813,56805-Nov-200703:00x64SP2

Windows Storage Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, your computer must be running Windows Storage Server 2003 with Service Pack 1 (SP1) or Windows Storage Server 2003 with Service Pack 2 (SP2).
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace a previously released hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Nfssvc.exe8.0.2254.1957,85618-Jul-200707:33x86
Nfssvr.sys8.0.2254.19449,02418-Jul-200707:33Not Applicable

Windows Services for UNIX 3.5

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To install this hotfix, you must be running Windows Services for UNIX 3.5.
Restart requirement
You must restart the computer to apply the changes after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.6231,416,19220-Dec-200609:28x86NoneRTMGDR
Ntdsa.dll5.2.3790.6231,432,06420-Dec-200609:30x86NoneRTMQFE
Ws03res.dll5.2.3790.62367,07219-Dec-200609:36x86NoneRTMQFE
Nfssvc.exe8.0.2254.1957,85626-Jul-200706:04x86NoneNot Applicable
Nfssvr.sys8.0.2254.19448,89626-Jul-200706:04Not ApplicableNoneNot Applicable
Ntdsa.dll5.2.3790.28511,623,04020-Dec-200609:44x86SP1SP1GDR
Ntdsa.hp.dll5.2.3790.285181,92020-Dec-200609:44x86SP1SP1GDR
Ntdsa.dll5.2.3790.28511,521,66420-Dec-200609:49x86SP1SP1QFE
W03a2409.dll5.2.3790.285127,13619-Dec-200613:31x86SP1SP1QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

When hotifx 939767 is uninstalled, a �STATUS_USER_MAPPED_FILE� error may occur. This error occurs because the Nfssvr.sys file [8.0.2254.19] has been overwritten. This file is located in the C:\WINDOWS\system32\drivers directory. The operating system overwrites the file with the old version of the Nfssvr.sys file that is located in the %WINDIR%\$NtUninstallKB939767 directory. Even if the copy file operation fails, the installation process is completed.

In Windows Storage Server 2003, when hotfix 939767 is uninstalled, the Nfssvr.sys module is not reverted to the old version. If this problem occurs, follow these steps:
  1. At a command prompt, type the following command to replace the active driver (Nfssvr.sys):
    inuse.exe %WINDIR%\$NtUninstallKB939767$\nfssvr.sys %WINDIR%\system32\drivers\nfssvr.sys
  2. Use the Add or Remove Programs item in Control Panel to remove hotfix 939767.
  3. Restart the computer.
  4. Verify the following items:
    • The version of the Nfssvr.sys file has reverted to the old version.
    • Hotfix 939767 has been removed from the Add or Remove Programs item.
    • The %WINDIR%\$NtUninstallKB939767$ directory has been removed.
    • The System and Application log files do not contain errors that are related to NFS.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB939767, kbqfe, kbHotfixServer, kbfix, kbbug, kberrmsg, kbautohotfix, kbmdd

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Article Info
Article ID : 939767
Revision : 6
Created on : 10/9/2014
Published on : 10/9/2014
Exists online : False
Views : 321