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The Automated Deployment Services 1.1 deployment agent does not start on a Windows Server 2003 SP2-based computer


View products that this article applies to.

Symptoms

When the Automated Deployment Services (ADS) 1.1 deployment agent tries to start on a Microsoft Windows Server 2003 Service Pack 2 (SP2)-based computer, the deployment agent does not start as expected.

This problem may occur even after you install the software update that is described in the following Microsoft Knowledge Base article:
937088 Image deployment fails when you try to deploy an image by using the Boot-to-da.xml template in ADS after you install Windows Server 2003 SP2

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Cause

This problem occurs because of a compatibility issue between ADS 1.1 and the built-in Ramdisk driver. This compatibility issue occurs when ADS 1.1 is running on a Windows Server 2003 SP2-based computer. When this problem occurs, the Ramdisk image is locked by the Ramdisk driver while the builder service tries to move the image from the pre-staging folder to the Trivial File Transfer Protocol (TFTP) folder.

After you install update 937088, you might encounter timing issues when the RAM disk is created. When this behavior occurs, the RAM disk is not created successfully. This problem typically occurs only on fast computers that have two-or-more processors.

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Resolution

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that this article describes. Apply this hotfix only to systems that are experiencing this specific problem.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site: The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Adsbuild.dll5.2.5149.1000141,31228-Jun-200718:05x86

Installation instructions

To resolve this issue, you must install update 937088 and the hotfix that is described earlier in the "Resolution" section.

Note For more information about update 937088, see the "Symptoms" section.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB939466, kbhotfixserver, kbexpertiseinter, kbpubtypekc, kbqfe

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Article Info
Article ID : 939466
Revision : 3
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 272