Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to process data in Fixed Assets in Microsoft Dynamics GP 9.0: “Error message [ID] not in 3rd Party Error Message Master”


View products that this article applies to.

SYMPTOMS

When you try to process data in Fixed Assets in Microsoft Dynamics GP 9.0, you receive the following error message:

       Error message ID not in 3rd Party Error Message Master.

Note In the error message, the ID placeholder is a placeholder for the error message ID.

↑ Back to the top


CAUSE

This problem occurs because the ALERT3RD table is missing records. The ALERT3RD table stores the error messages that you can receive in Fixed Assets.

↑ Back to the top


RESOLUTION

To resolve this problem, insert the missing records into the ALERT3RD table. To do this, follow these steps.

Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.
1. Have all users exit Microsoft Dynamics GP.
2.

Start the Support Administrator Console, Microsoft SQL Query Analyzer, or SQL Server Management Studio. To do this, use one of the following methods depending on the program that you are using.

Method 1: For SQL Server Desktop Engine

If you are using SQL Server Desktop Engine (also known as MSDE 2000), start the Support Administrator Console. To do this, click Start , point to All Programs , point to Microsoft Administrator Console , and then click Support Administrator Console .

Method 2: For SQL Server 2000

If you are using SQL Server 2000, start SQL Query Analyzer. To do this, click Start , point to All Programs , point to Microsoft SQL Server , and then click Query Analyzer .

Method 3: For SQL Server 2005

If you are using SQL Server 2005, start SQL Server Management Studio. To do this, click Start , point to All Programs , point to Microsoft SQL Server 2005 , and then click SQL Server Management Studio .
3. Run the following statement against the DYNAMICS database to insert the missing records into the ALERT3RD table from the Alert3rd.out file.
/* start of fix script */ 
Use DYNAMICS 
truncate table ALERT3RD 

bulk insert ALERT3RD 
from 'C:\Program Files\Microsoft Dynamics\GP\SQL\Install\309\System\Data\ALERT3RD.OUT' 
with 
( DATAFILETYPE = 'char' 
, ROWTERMINATOR = '#EOR#\n' 
, FIELDTERMINATOR = '||' 
) 
/* end of fix script */

 
Note By default, the Alert3rd.out file is in following location:

C:\Program Files\Microsoft Dynamics\GP\SQL\Install\309\System\Data\Alert3rd.out

If the Alert3rd.out file is in a different location, change the script to use the correct location.
4. Start Microsoft Dynamics GP. Verify that you no longer receive the error message in Fixed Assets.

↑ Back to the top


Keywords: kb, kbnosurvey, kbMBSMigrate, kbMBSPartner, kbtshoot, kbprb, kbExpertiseInter, BemisKB939282, kberrmsg

↑ Back to the top

Article Info
Article ID : 939282
Revision : 2
Created on : 3/1/2017
Published on : 3/1/2017
Exists online : False
Views : 285