Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2003 Service Pack 1 or Service Pack 2-based computer seems to stop responding when the Lsass.exe process consumes lots of memory and uses 100% of the CPU


View products that this article applies to.

Symptoms

A Windows Server 2003 Service Pack 1 (SP1) or SP2-based computer seems to stop responding when the following conditions are true for the Lsass.exe process:
  • The process stops responding.
  • The process consumes lots of memory.
  • The process uses 100% of the CPU.
However, the computer responds to Internet Control Message Protocol (ICMP) ping requests.

↑ Back to the top


Cause

This problem occurs because of a code defect in the NTLM authentication package.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Service Pack 2 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 917257.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Msv1_0.dll5.2.3790.3026144,89616-Oct-200709:23x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Msv1_0.dll5.2.3790.4170131,07216-Oct-200709:33x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Msv1_0.dll5.2.3790.3026390,14416-Oct-200707:16IA-64Not Applicable
Wmsv1_0.dll5.2.3790.3026144,89616-Oct-200707:16x86WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Msv1_0.dll5.2.3790.4170375,80816-Oct-200707:46IA-64Not Applicable
Wmsv1_0.dll5.2.3790.4170131,07216-Oct-200707:46x86WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Msv1_0.dll5.2.3790.3026260,09616-Oct-200707:16x64Not Applicable
Wmsv1_0.dll5.2.3790.3026144,89616-Oct-200707:16x86WOW
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Msv1_0.dll5.2.3790.4170206,33616-Oct-200707:49x64Not Applicable
Wmsv1_0.dll5.2.3790.4170131,07216-Oct-200707:49x86WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about a Windows Server 2003 Service Pack 1-based computer that seems to stop responding when the Lsass.exe process undergoes high memory and high CPU usage, click the following article number to view the article in the Microsoft Knowledge Base:
917257 A Windows Server 2003 Service Pack 1-based computer seems to stop responding when the Lsass.exe process undergoes high memory and high CPU usage
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Call stack information

When this problem occurs, you may see call stack information that resembles the following.
0: kd> kb
ChildEBP RetAddr  Args to Child              
0252f330 7c807095 76cb04e0 0252f37c 00631ce0 msv1_0!SspSplayCompare+0x14
0252f348 7c806e89 0252f37c 0252f364 0252f3b8 ntdll!FindNodeOrParent+0x1b
0252f35c 76c94c36 76cb04e0 0252f37c 0000003e ntdll!RtlInsertElementGenericTable+0x15
0252f3d0 76c94ab9 00a5e570 01615488 6b637453 msv1_0!SspInsertChallenge+0x146
0252fa78 76c92d9f 00000000 0252fc6c 00000003 msv1_0!SsprHandleChallengeMessage+0x166a
0252fc88 742c9649 00000000 01615488 0252fe6c msv1_0!SpInitLsaModeContext+0x235
0252fd00 742c9472 01eb84f0 01eb84f8 0252fe6c LSASRV!WLsaInitContext+0x12b
0252fe84 742c3b02 01eb84c8 0069dd38 01705fd0 LSASRV!LpcInitContext+0x165
0252fe9c 742c3a05 01eb84c8 74373738 01ecbb28 LSASRV!DispatchAPI+0x46
0252ff54 742c3035 01eb84c8 0252ff9c 77e68cbd LSASRV!LpcHandler+0x1fe
0252ff78 7431114a 0061c510 00000000 00000000 LSASRV!SpmPoolThreadBase+0xb9
0252ffb8 77e6608b 00665e70 00000000 00000000 LSASRV!LsapThreadBase+0x57
0252ffec 00000000 742e7414 00665e70 00000000 kernel32!BaseThreadStart+0x34

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbqfe, kbHotfixServer, KB939268

↑ Back to the top

Article Info
Article ID : 939268
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 238