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You cannot use a 3DES-based Secure Sockets Layer (SSL) connection to connect to Exchange 2003


View products that this article applies to.

Symptoms

When you use an Internet Message Access Protocol, version 4rev1 (IMAP4) client or a Post Office Protocol version 3 (POP3) client to connect to Microsoft Exchange Server 2003, the connection fails. This problem occurs if the following conditions are true:
  • You are using a Secure Sockets Layer (SSL) connection.
  • A block ciphers algorithm, such as Triple DES (3DES), is used for the SSL encryption.
The clients receive different error codes depending on which client is used to connect the Exchange 2003 server. For example, a Microsoft Office Outlook client receives error code "0x800CCC0E." Additionally, a Microsoft Outlook Express client receives error code "0x800CCC0F." Other software vendors may use their own error codes to report the error.

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Cause

Block ciphers algorithms are unusual because they change the size of the data that is encrypted. When the encrypted data is returned, the size of the data may be smaller than the size of the data that was sent to be encrypted. In other words, the size of the encrypted data that the Exchange 2003 server sends back to the client is different by several bytes. For example, a program uses an SSL connection to send 1,000 bytes of data to be encrypted. When the data is encrypted and then returned to the client, the size of the data is 980 bytes. This can remove the client's ability to decrypt the encrypted data.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Microsoft Exchange Server 2003 Service Pack 2 (SP2) must be installed before you apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Internet Information Services (IIS) Admin Service and all dependent services are restarted automatically when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Iisproto.dll6.5.7653.9133,63209-Jul-200718:18

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:
904983 You cannot connect to a server that is running Exchange 2000 Server or Exchange Server 2003 to download e-mail messages when you use IMAP4 or POP3 through a Secure Sockets Layer (SSL) connection
For more information about SSL and about corresponding cipher suits, visit the following Microsoft Web site:

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Keywords: KB938857, kbexpertiseinter, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 938857
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 202