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You cannot communicate with the local device by using a redirected COM port in a Windows Server 2003-based terminal-server session


View products that this article applies to.

Symptoms

Consider the following scenario. You create a terminal-server session from a client computer to a Microsoft Windows Server 2003-based terminal server. A device is connected to a COM port on the client computer. However, you cannot use the redirected COM port in the terminal-server session to communicate with the device.

For example, if a printer is connected to the COM port on the client computer, you cannot print documents by using the redirected COM port. This problem occurs if the following conditions are true:
  • An application transfers data by using a redirected COM port in a terminal-server session.
  • The application uses the _fsopen function or other related functions to transfer data by using the redirected COM port.
  • The application is compiled by Microsoft C++ compilers.

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Cause

This problem occurs because the GetFileType function cannot determine the correct device type for the redirected COM port. When an application communicates with the redirected COM port, the application may use the _fsopen function or other related functions to open file streams. In Microsoft Visual C++, these functions are used to call the CreateFile function and the GetFileType function.

The GetFileType function cannot determine the correct device type for the redirected COM port. Instead, the GetFileType function returns a FILE_TYPE_UNKNOWN value. Therefore, the _fsopen function fails.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.2952200,19208-Jun-200713:43x86
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.4096200,19208-Jun-200718:08x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.2952641,02409-Jun-200701:13IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.4096640,51209-Jun-200701:20IA-64
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.2952332,80009-Jun-200701:12x64
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rdpdr.sys5.2.3790.4096333,82409-Jun-200701:51x64

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Workaround

To work around this problem, use other types of redirected ports instead of a redirected COM port. For example, use a redirected LPT port or a redirected USB port.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB938645

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Article Info
Article ID : 938645
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 229