Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Error message when you publish an orchestration that is converted from a BizTalk Server 2004 project in BizTalk Server 2006: Failed to create project


View products that this article applies to.

Symptoms

When you publish an orchestration from a Microsoft BizTalk Server 2004 project as a Web service on a computer that is running Microsoft BizTalk Server 2006, you receive the following error message:
Failed to create project http://localhost/MicrosoftTest.
Failed to construct code for schema "".
Object reference not set to an instance of an object.
Object reference not set to an instance of an object.
This problem occurs when the project that contains the orchestration is converted from BizTalk Server 2004 to BizTalk Server 2006.

The error message does not occur when you publish the same orchestration in BizTalk Server 2004.

↑ Back to the top


Cause

The issue occurs because the null target namespace property is allowed in BizTalk Server 2004. The null target namespace property is not allowed in BizTalk Server 2006. When you convert a project that includes an orchestration from BizTalk Server 2004, the target namespace property in schemas may be null. Therefore, when you publish the orchestration as a Web service on the BizTalk Server 2006 server, the Web publishing wizard may fail because of a null namespace reference that is caused by the null target namespace property in schemas.

↑ Back to the top


Workaround

To work around this issue, add the target namespace property to the schemas manually before you publish the orchestration as a Web service.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have the Microsoft BizTalk Server 2006 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.webservices.dll3.5.1682.0263,56004-Jun-200719:04x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB938567, kbqfe, kbhotfixserver, kbexpertiseinter, kbbiztalk2006presp1fix, kbbtsorchestration, kbautohotfix

↑ Back to the top

Article Info
Article ID : 938567
Revision : 4
Created on : 10/18/2007
Published on : 10/18/2007
Exists online : False
Views : 413