Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you run a sales transaction integration that has extended pricing enabled for an item on promotion in Integration Manager for Microsoft Dynamics GP: "Please close the Sales Item Detail Entry window before continuing"


Symptoms

When you run a sales transaction integration that has extended pricing enabled for an item on promotion, you receive the following error message:
Please close the Sales Item Detail Entry window before continuing.
This problem occurs in Integration Manager in Microsoft Dynamics GP 9.0 or in Microsoft Business Solutions - Great Plains 8.0.

This problem occurs if the Override Prices option is not enabled on the Options tab in the Sales Order Processing window.



Note When you run the sales transaction integration in Integration Manager in Microsoft Dynamics GP 9.0, no window is open.

↑ Back to the top


Cause

This problem occurs because Microsoft Dynamics GP is using the promotion price together with the extended price option.

Note When you run an integration for an item on promotion, the Promotion Alert window opens. In this window, users can accept or reject the promotion price. However, Integration Manager cannot use the information in this window.

↑ Back to the top


Resolution

Integration Manager in Microsoft Business Solutions - Great Plains 8.0

To resolve this problem, obtain the latest service pack for Integration Manager in Microsoft Business Solutions - Great Plains 8.0. For more information, visit one of the following Microsoft Web sites, depending on whether you are a partner or a customer.


PartnersCustomersNote This service pack adds a Promotion Alert option to the Sales Transactions Options tab. Users can accept or reject the promotion price. The default setting is to accept the promotion price.

↑ Back to the top


Status

Integration Manager in Microsoft Dynamics GP 9.0

Microsoft is researching this problem and will post more information in this article when the information becomes available.

↑ Back to the top


Integration Manager in Microsoft Business Solutions - Great Plains 8.0

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was corrected in Service Pack 5 for Integration Manager in Microsoft Business Solutions - Great Plains 8.0.

↑ Back to the top


Keywords: kbnosurvey, kbexpertiseadvanced, kbmbspartner, kbexpertisebeginner, kbtshoot, kbmbsmigrate, kbbug, kbexpertiseinter, kb

↑ Back to the top

Article Info
Article ID : 938562
Revision : 1
Created on : 3/3/2017
Published on : 11/2/2013
Exists online : False
Views : 75