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The GetUserNameEx function returns the user name in an incorrect format in Windows Server 2003


View products that this article applies to.

Symptoms

In Microsoft Windows Server 2003, you call the GetUserNameEx function to retrieve the Security Account Manager (SAM)-compatible user name. The SAM-compatible user name is retrieved by impersonating the client token. However, if you use the NameSamCompatible value as the NameFormat parameter, the GetUserNameEx function returns the user name in an incorrect format.

You expect the following user name format:
NetBIOS_Domain\User_Name
However, the format of the returned user name is as follows:
DNS_Domain\UPN
Note The NetBIOS_Domain placeholder represents the NetBIOS domain name for the user. The User_Name placeholder represents the SAM account name for the user. The DNS_Domain placeholder represents the Domain Name System (DNS) domain name for the user. The UPN placeholder represents the user principal name for the user.

Applications may experience unexpected issues if software developers have assumed that the returned user name is formatted correctly.

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Cause

This problem occurs because the Kerberos component in Windows Server 2003 applies an incorrect check before the returned user name is formatted. The check causes the NetBIOS domain name in the Kerberos token to be absent.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Kerberos.dll5.2.3790.2944351,74431-May-200708:44x86
Windows Server 2003 with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kerberos.dll5.2.3790.4090351,23231-May-200709:02x86
Windows Server 2003 with SP1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kerberos.dll5.2.3790.2945966,14430-May-200718:42IA-64SP1Not Applicable
Wkerberos.dll5.2.3790.2944351,74430-May-200718:42x86SP1WOW
Windows Server 2003 with SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kerberos.dll5.2.3790.4090968,19230-May-200718:45IA-64SP2Not Applicable
Wkerberos.dll5.2.3790.4090351,23230-May-200718:45x86SP2WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kerberos.dll5.2.3790.2945722,43230-May-200718:41x64SP1Not Applicable
Wkerberos.dll5.2.3790.2944351,74430-May-200718:41x86SP1WOW
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Kerberos.dll5.2.3790.4090600,57630-May-200718:44x64SP2Not Applicable
Wkerberos.dll5.2.3790.4090351,23230-May-200718:44x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the GetUserNameEx function, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB937919

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Article Info
Article ID : 937919
Revision : 5
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 251