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Error message when you try to save an activity in the Microsoft Dynamics CRM client for Outlook: "Microsoft CRM Unhandled Error Details: Server Error in '/' Application"


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Symptoms

When you try to save an activity in the Microsoft Dynamics CRM 3.0 client for Microsoft Office Outlook, you may receive the following error message:
Microsoft CRM Unhandled Error Details:
Server Error in '/' Application.

Exception from HRESULT: 0x80040115.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException:
Exception from HRESULT: 0x80040115.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[COMException (0x80040115): Exception from HRESULT: 0x80040115.]
Microsoft.Crm.Platform.ComProxy.CRMContactClass.Create(CUserAuth& Caller, String Contact) +0
Microsoft.Crm.Application.Platform.Contact.InternalCreate(String xml) +268
Microsoft.Crm.Application.Platform.Entity.Create() +109
Microsoft.Crm.Application.Forms.AppForm.RaiseDataEvent(FormEventId eventId) +408
Microsoft.Crm.Application.Forms.EndUserForm.Initialize(Entity entity) +57
Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity, String formId, String formType) +83
Microsoft.Crm.Application.Forms.CustomizableForm.Execute(Entity entity) +13
Microsoft.Crm.Web.SFA.ContactDetailPage.ConfigureForm() +244
Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) +29
System.Web.UI.Control.PreRenderRecursiveInternal() +54 System.Web.UI.Page.ProcessRequestMain() +1499

Microsoft CRM Platform Error Report:
Error Description:
Exception from HRESULT: 0x80040115.

Error Details:
Exception from HRESULT: 0x80040115.

Error Number:
0x80040115

Source File:
Not available

Line Number:
Not available
This problem occurs if the following conditions are true:
  • You try to save one of the following activities:
    • Contact
    • Task
    • Appointment
    • Service
  • You click Go Offline in the Microsoft Dynamics CRM client for Outlook, and then you disconnect the computer that is running the Microsoft Dynamics CRM client for Outlook from the network.

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Cause

This problem occurs because a MAPI_E_NETWORK_ERROR error stops the IMsgStore->OpenEntry function.

Note The IMsgStore->OpenEntry function is defined in the OutlookItemFinder.cpp file.

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Resolution

To resolve this problem, enable the Use Cached Exchange Mode feature in Outlook. To do this, follow these steps:
  1. Start Outlook.
  2. On the Tools menu, click Account Settings.
  3. Click the e-mail account that you use, and then click Change.
  4. Click to select the Use Cached Exchange Mode check box, and then click Next.
  5. Click Finish.
  6. Click Close.

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Keywords: KB937878, kbexpertisebeginner, kbexpertiseinter, kbmbsmigrate, kbprb, kbtshoot, kberrmsg

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Article Info
Article ID : 937878
Revision : 2
Created on : 8/15/2007
Published on : 8/15/2007
Exists online : False
Views : 299