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A console application may stop responding when you start it on a computer that is running Windows Server 2003 or Windows XP Professional x64 Edition


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP Professional x64 Edition, a console application may stop responding soon after you start it. When this problem occurs, the application process appears in Task Manager. However, you cannot view the application's window. Usually, this problem occurs in the following scenario:
  • A console application that has registered control handlers is closing.
  • You restart the console application before an End Program dialog box appears.
Note If the control handlers of a console application do not respond, Windows Server 2003 eventually displays an End Program dialog box to let you close the application. This problem does not occur if you start the application after you dismiss the End Program dialog box.

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Cause

This problem occurs because the Csrss.exe process does not handle console startup messages when a console application control handler is busy.

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Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Windows Server 2003 Service Pack 1 or Microsoft Windows Server 2003 Service Pack 2 installed. For more information about how to obtain the latest service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.4082301,05616-May-200717:08x86
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.4082513,53616-May-200702:33x64
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.4082819,71216-May-200702:36IA-64
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.2937299,52016-May-200716:54x86
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.2937513,53616-May-200702:27x64
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.2937819,71216-May-200702:27IA-64

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Windows XP Professional x64 Edition Service Pack 1 or Windows XP Professional x64 Edition Service Pack 2 installed. For more information about how to obtain the latest service pack, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Professional x64 Edition with Service Pack 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.4082513,53616-May-200702:33x64
Windows XP Professional x64 Edition with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winsrv.dll5.2.3790.2937513,53616-May-200702:27x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB937342, kbqfe, kbhotfixserver, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 937342
Revision : 4
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 269