Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you run the Operations Manager Prerequisite Viewer for the Server component: "Microsoft.interop.security.azroles.dll is not registered in the global assembly cache"


View products that this article applies to.

Symptoms

When you run the Microsoft System Center Operations Manager 2007 Prerequisite Viewer for the Server component, the prerequisite check returns the following failure status:
Microsoft.interop.security.azroles.dll is not registered in the global assembly cache

↑ Back to the top


Cause

This problem occurs if the primary interoperability assembly (Microsoft.interop.security.azroles.dll) is no longer registered in the global assembly cache after you install Microsoft Windows Server 2003 with Service Pack 1 or Windows Server 2003 with Service Pack 2.

↑ Back to the top


Resolution

To resolve this problem in Windows Server 2003 with Service Pack 1, apply the hotfix that is mentioned in article 915786. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
915786 Authorization Manager-enabled applications may not work after you install Windows Server 2003 Service Pack 1
To resolve this problem in Windows Server 2003 with Service Pack 2, re-register the primary interoperability assembly in the global assembly cache. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type the following commands. Press ENTER after each command.
    cd %windir%\Microsoft.NET\AuthMan\1.2
    azrlreg register Microsoft.interop.security.azroles.dll
  3. Run the Operations Manager Prerequisite Viewer to execute the check again for the Server component.

↑ Back to the top


More information

To run the Operations Manager 2007 Prerequisite Viewer on the computer that you want to evaluate, follow these steps:
  1. Double-click the Setupom.exe file on the Operations Manager 2007 installation disc.
  2. On the Start page, click Check Prerequisites.
  3. Click to select the Server check box for the server for which you want to evaluate prerequisites. Then click Check to display the status of prerequisites for the selected Operations Manager 2007 components.

↑ Back to the top


Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB937292, kbtshoot, kbexpertiseinter, kbbug

↑ Back to the top

Article Info
Article ID : 937292
Revision : 3
Created on : 5/16/2007
Published on : 5/16/2007
Exists online : False
Views : 259