Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A migrated virtual machine image may not start successfully, even when all the scripts run successfully on a Microsoft Windows Server 2003-based computer that is running Automated Deployment Services


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry

↑ Back to the top


Symptoms

Consider the following scenario:
You have a Microsoft Windows Server 2003-based computer that is running Automated Deployment Services (ADS).
On this computer, you use Virtual Server 2005 Migration Toolkit (VSMT) to migrate a physical computer onto a virtual machine image.
In this scenario, the virtual machine may not start successfully, even though all the scripts run successfully. Additionally, you may receive the following Stop error after the virtual machine starts:
Stop 0x0000007B

↑ Back to the top


Cause

This issue occurs when the physical computer does not load the HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001 registry subkey when the computer starts. Instead, the physical computer loads a different subkey, such as HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002.

↑ Back to the top


Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, use Registry Editor to examine the HKEY_LOCAL_MACHINE\SYSTEM\Select\Current registry subkey. Determine the value of the Current registry entry and the value of the Default registry entry. Then, change the VSMT scripts before you perform the migration. To do this, follow these steps:
1.Before you run the VSMT scripts on the physical computer, use Registry Editor to determine the value of Current registry entry and the value of the Default registry entry. To do this follow these steps:
a. Click Start, click Run, type regedit, and then click OK.
b. In Registry Editor, locate the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\Select
c. Note the value of the Current registry entry and the value of the Default registry entry. These values will match.
2.In Windows Explorer, locate the following folder:
%Systemroot%\Program Files\Microsoft VSMT\P2V\MachineName
3.Right-click ServiceDriver.xml, point to Open With, and then click Notepad.
4.In the file, replace each instance of "ControlSet001" based on the value that you noted in step 1c.

For example, if the value that you noted in step 1c is 0x00000002, replace each instance of "ControlSet001" with "ControlSet002."
5.Click Save to save the changes.
6.In Windows Explorer, locate the following folder:
%Systemroot%\Program Files\Microsoft VSMT\P2V\MachineName\Patches
7.Right-click Storage.xml, point to Open With, and then click Notepad.
8.In the file, replace each instance of "ControlSet001" based on the value that you noted in step 1c.
9.Click Save to save the changes.
10.Repeat steps 8 and 9 for the following files:
StorageSCSI.xml
Uniproc.xml

↑ Back to the top


Keywords: KB937227, kbprb, kbexpertiseinter, kbtshoot

↑ Back to the top

Article Info
Article ID : 937227
Revision : 4
Created on : 10/31/2007
Published on : 10/31/2007
Exists online : False
Views : 167