Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: An MT965 message is rejected by BizTalk Accelerator for SWIFT 2.3 when the MTS965 message does not contain an optional CTR subfield in the 91F field


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install Microsoft BizTalk Accelerator for SWIFT 2.3 Service Pack 1 (SP1) on a computer that is running Microsoft BizTalk Server 2006.
  • You install BizTalk Accelerator for SWIFT 2.3 Message Pack 2006 on the same computer.
  • You run a developed application that uses BizTalk Accelerator for SWIFT 2.3.
  • You submit an MTS965 message that does not contain an optional CTR subfield in the 91F field.
In this scenario, the MT965 message is rejected by BizTalk Accelerator for SWIFT 2.3.

↑ Back to the top


Cause

This problem occurs because of a problem in the following files in the original BizTalk Accelerator for SWIFT 2.3 Message Pack 2006:
  • MT965.xsd
  • MT965.xsn

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of the file dependencies, you must install the following products before you install this hotfix on the server:
  • BizTalk Server 2006
  • BizTalk Accelerator for SWIFT 2.3 SP1
  • BizTalk Accelerator for SWIFT 2.3 Message Pack 2006

Restart requirement

After you install this hotfix, you have to restart the following components:
  • Internet Information Services (IIS) and all dependent services
  • The host instance in the BizTalk Server 2006 Administration console

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mt965.xsdNot applicable147,55208-May-200717:00Not applicable
Mt965.xsnNot applicable88,82509-May-200706:11Not applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB937164, kbhotfixserver, kbqfe, kbexpertiseinter, kbautohotfix

↑ Back to the top

Article Info
Article ID : 937164
Revision : 3
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 449