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Performance is poor in a WPF-based application in which you have enabled layered windows in Windows XP or in Windows Server 2003


View products that this article applies to.

Symptoms

A computer has the Microsoft .NET Framework 3.0 installed. In an application that is based on the Windows Presentation Foundation (WPF), you enable layered windows by setting the value of the Windows.AllowsTransparency windows property to TRUE. In this configuration, the performance of the WPF-based application is poor. Additionally, you may notice the following problems:
  • Jittery animation
  • Lower frame rate
  • High CPU usage

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Cause

This problem occurs because layered windows enable the transparency effects of the top-level window. WPF-based applications render graphics by using the DirectX pipeline. In DirectX 9.0c, the IDirect3DSurface9::GetDC method does not support transparency effects that use an alpha channel. Therefore, graphics that a WPF-based application renders are not hardware-accelerated. Instead, the application renders graphics at the software level. In this situation, the application performs poorly and uses a high proportion of CPU time.

Note DirectX 9.0c is included with Microsoft Windows XP with Service Pack 2, with Microsoft Windows Server 2003 with Service Pack 1, and with Windows Server 2003 with Service Pack 2.

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Resolution

Hotfix information

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
D3d9.dll5.3.2600.31331,689,08807-May-200713:49x86

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
D3d9.dll5.3.3790.29431,690,62425-May-200706:24x86SP1SP1QFE
D3d9.dll5.3.3790.40871,690,62425-May-200705:03x86SP2SP2QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
D3d9.dll5.3.3790.29432,098,17624-May-200715:42x64SP1SP1QFE
Wd3d9.dll5.3.3790.29431,690,62424-May-200715:42x86SP1WOW
D3d9.dll5.3.3790.40872,098,17624-May-200715:57x64SP2SP2QFE
Wd3d9.dll5.3.3790.40871,690,62424-May-200715:57x86SP2WOW

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Workaround

To work around this problem, disable layered windows in WPF-based applications.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Apply this hotfix only to computers on which WPF-based applications do not use hardware acceleration to render graphics.

If you set the color quality to Medium (16 bit) in the Display Properties dialog box, the performance of certain video drivers may decrease in layered windows. To avoid this problem, set the color quality to Highest (32 bit).

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Keywords: kbautohotfix, kbwinxppresp3fix, kbwinserv2003postsp2fix, kbfix, kbhotfixserver, kbqfe, kbexpertiseinter, KB937106

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Article Info
Article ID : 937106
Revision : 6
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 496