Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you open a Microsoft Dynamics NAV 4.x database in Microsoft Dynamics NAV 5.x: "You do not have permission to modify the [TableName] Table"


View products that this article applies to.

This article applies to Microsoft Dynamics NAV 5.0 for all countries and all language locales.

↑ Back to the top


Symptoms

When you open a Microsoft Dynamics NAV 4.x database in Microsoft Dynamics NAV 5.x, you receive an error message that resembles the following error message:
You do not have permission to modify the TableName Table.
Note The TableName placeholder represents the name of the table.

This problem occurs if the following conditions are true:
  • The clustered property on the primary key is changed to Yes for all the tables.
  • The database is upgraded to Microsoft Dynamics NAV 5.0.

↑ Back to the top


Cause

This problem occurs because the database contains objects for which the current license does not have permissions.

↑ Back to the top


Workaround

To work around this problem, follow these steps:
  1. Make a backup of the Microsoft Dynamics NAV 4.x database.
  2. Create a new database in Microsoft Dynamics NAV 5.x.
  3. Restore the backup.

↑ Back to the top


Resolution

A supported hotfix is now available from Microsoft. The hotfix corrects the problem that is described in this article. Apply the hotfix only to systems that are experiencing this specific problem.

To resolve this problem immediately, contact Technical Support for Microsoft Dynamics and related products to obtain the hotfix. You can log on to the Microsoft Dynamics site and create a new support request. To do this, visit the following Microsoft Web site: You can also contact Technical Support for Microsoft Dynamics and related products by telephone at (888) 477-7877.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


↑ Back to the top


Prerequisites

You must have Microsoft Dynamics NAV 4.0 installed to apply this hotfix.

Removal information

You cannot remove this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

How to obtain the Microsoft Dynamics NAV hotfix or update files

After you request a Microsoft Dynamics NAV hotfix or an update file from Technical Support for Microsoft Dynamics, a hyperlink will be sent to you in an e-mail.


The e-mail will contain a hyperlink and a password. You can use the hyperlink to download the Microsoft Dynamics NAV hotfix or the update files. When you click the hyperlink, the File Download – Security Warning dialog box opens. Then, you are prompted to run, to save, or to cancel the download.


If you click Run, the files start the download and the extraction process. You must specify a folder for the new files, and then provide the password.


If you click Save, you must specify a path for saving the compressed file. When you open the file that you saved, you are prompted to specify a path for the files. You must then provide the password provided in the e-mail.


If you click Cancel, the download process stops.

How to install a Microsoft Dynamics NAV hotfix or an update file


The Microsoft Dynamics NAV platform hotfixes and updates are made available as single files. To install a Microsoft Dynamics NAV hotfix or an update, you must replace the existing Microsoft Dynamics NAV installation files with the hotfix or the update files. To do this, follow these steps.



If you have Microsoft Dynamics NAV Application Server installed, you must replace the following files in the Microsoft Dynamics NAV Application Server installation.
File nameFile versionFile sizeDateTimePlatform
Fin.exe5.0.24632.010,737,10423-May-200701:30x86
Finsql.exe5.0.24632.010,794,44823-May-200701:30x86
To replace the files, follow these steps:
  1. Stop all Microsoft Dynamics NAV activity.
  2. Locate the Microsoft Dynamics NAV Open Database Connectivity (ODBC) driver installation directory. The Microsoft Dynamics NAV ODBC driver is usually installed in the following directory:
    C:\Program Files\Common Files\Navision\NODBC\
  3. Copy the files that you downloaded.
  4. Paste the files that you downloaded into the Microsoft Dynamics NAV ODBC driver installation directory.
  5. Click Yes to overwrite the files in the directory.

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbmbsdatabaseandplatforms, kbexpertiseinter, kbentirenet, kbmbspartner, kbmbsmigrate, kb, kberrmsg

↑ Back to the top

Article Info
Article ID : 936885
Revision : 2
Created on : 1/31/2017
Published on : 1/31/2017
Exists online : False
Views : 304