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Yellow exclamation mark appears next to the Firewall Client icon on a computer that is running a particular version of the Firewall Client for ISA Server, and a tool tip message is displayed: “Firewall Client is not installed properly”


Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry

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Symptoms

You find a yellow exclamation mark next to the Firewall Client icon. This problem occurs on a computer that is running the version of the Firewall Client for ISA Server that is described in the Microsoft Knowledge Base article 929556. Additionally, when you move the mouse pointer over the Firewall Client icon, a tool tip message is displayed that resembles the following:
Firewall Client is not installed properly

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Cause

This problem occurs if you are running a program that installs WinSock Base Service Provider (BSP), such as mobile phone connection optimizers. A BSP may bypass the Firewall Client BSP and affect the correct functioning of the Firewall Client. To caution you about this situation, the Firewall Client displays a warning message.

However, some BSPs do not bypass the Firewall Client BSP. Therefore, these BSPs do not affect the functioning of the Firewall Client. If you have tested your program, and if you have verified that it does not affect the correct functioning of the Firewall Client, you can disable the tool tip warning message. To disable this tool tip warning message, install the hotfix that is described in the "Resolution" section.

After you install the hotfix, you must add the UiEnableCatalogValidation registry entry to enable the hotfix. For more information about how to add this registry entry, see the "Windows registry information" section.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Fwcmgmt.exe4.0.3442.700120,20820-May-200716:39Not Applicable

Windows registry information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, you must add the UiEnableCatalogValidation registry entry to enable this hotfix. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    On 32-bit computers:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Firewall Client 2004\Policies

    On 64-bit computers:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Firewall Client 2004\Policies
  3. On the Edit menu, click New, and then click DWORD Value.
  4. Type UiEnableCatalogValidation, and then press ENTER.
  5. Right-click UiEnableCatalogValidation, and then make sure that the Value data box contains a null value (0).

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about how to obtain the version of Firewall Client for ISA Server (December 2006) that includes Windows Vista support, click the following article number to view the article in the Microsoft Knowledge Base:

929556 How to obtain the version of Firewall Client for ISA Server (December 2006) that includes Windows Vista support

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbpubtypekc, kbqfe, kbentirenet, kbexpertiseinter, kb

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Article Info
Article ID : 936773
Revision : 3
Created on : 11/26/2018
Published on : 11/26/2018
Exists online : False
Views : 76