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FIX: Some characters of the "Long Text" data type are incorrectly imported when you import a catalog XML file in Commerce Server 2007


View products that this article applies to.

Symptoms

In Microsoft Commerce Server 2007, you import a catalog XML file by using Catalog Manager or by using Commerce Server Staging. When you do this, some characters of the Long Text data type are incorrectly imported as Unicode characters.

Specifically, some Turkish characters are converted to Latin characters. For example, the following Turkish characters are converted:
  • The s character is converted to the s character.
  • The i character is converted to the i character.
  • The g character is converted to the g character.

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Cause

This problem occurs because the catalog import operation incorrectly converts some characters to Unicode characters if the characters are included in a field that has the Long Text data type.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Commerce Server 2007 to be installed on the server because of file dependencies.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.catalogserver.dll6.0.4012.0746,87210-May-200700:46x86

Installation information

After you download the hotfix, follow these steps:
  1. Back up the existing Microsoft.catalogserver.dll file that is located in the following folder:
    C:\Program Files\Microsoft Commerce Server 2007\Assemblies
  2. Copy the Microsoft.catalogserver.dll file from the hotfix folder to the following folder:
    C:\Program Files\Microsoft Commerce Server 2007\Assemblies
  3. To install the assembly to the global assembly cache, run the following command:
    gacutil /i "C:\Program Files\Microsoft Commerce Server 2007\Assemblies\Microsoft.CatalogServer.dll"
  4. Restart the server that is running Commerce Server 2007.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB936730, kbqfe, kbhotfixserver, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 936730
Revision : 3
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 408