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A temporary copy of an attachment is not deleted when you send an e-mail message that contains the attachment in Microsoft Dynamics CRM


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Symptoms

Consider the following scenario. You create a new e-mail message in Microsoft Dynamics CRM 3.0 that contains an attachment. As expected, a temporary copy of the attached file is created on the computer in the Microsoft Outlook temporary folder in the "Temporary Internet Files" folder. However, when the e-mail message is sent, the temporary copy of the attachment is not deleted.

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Cause

This behavior occurs if the following conditions are true:
  • The Microsoft Dynamics CRM 3.0 add-in is enabled in Outlook.
  • Microsoft Word is not used to edit e-mail messages in Outlook.

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Workaround

To work around this behavior, use one of the following methods.

Method 1: Use Word as the e-mail editor in Outlook

To use Word as the e-mail editor in Outlook, follow these steps:
  1. Start Outlook.
  2. On the Tools menu, click Options.
  3. Click the Mail Format tab.
  4. Click to select the Use Microsoft Office Word 2003 to edit e-mail messages check box. Then, click OK.

Method 2: Delete the temporary files in the Outlook temporary folder

To delete the temporary copy of the e-mail attachment, you must first determine the location of the Outlook temporary folder. Then, you must delete the files in the Outlook temporary folder. To do this, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and select the following subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security
  3. In the details pane, locate OutlookSecureTempFolder in the Name column. Note the path in the Data column. In this scenario, the Outlook temporary folder path may resemble the following path:
    C:\Documents and Settings\user_name\Local Settings\Temporary Internet Files\OLKC\
  4. On the File menu, click Exit to exit Registry Editor.
  5. Start Windows Explorer. To do this, right-click Start, and then click Explore.
  6. Locate and then select the folder that you noted in step 3.
  7. On the Edit menu, click Select All.

    Note All the files in the Outlook temporary folder are selected. In this scenario, the Outlook temporary folder is the OLKC folder.
  8. On the File menu, click Delete.

    Note If you are prompted to delete the files, click Yes.
  9. On the File menu, click Close to exit Windows Explorer.

Method 3: Upgrade to Microsoft Office Outlook 2007

Microsoft Office Outlook 2007 uses Microsoft Word as the e-mail editor. You cannot turn off this option. Therefore, the behavior that is mentioned in the "Symptoms" section will not occur in Outlook 2007 together with Microsoft Dynamics CRM 3.0.

For more information about Outlook 2007, visit the following Microsoft Web site:

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Keywords: KB936639, kbexpertisebeginner, kbexpertiseinter, kbmbsmigrate, kbemail, kbprb, kbtshoot

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Article Info
Article ID : 936639
Revision : 2
Created on : 8/15/2007
Published on : 8/15/2007
Exists online : False
Views : 417