Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to access shared resources after a VPN connection is established from a Windows Vista-based computer to a Windows Server 2003-based server: "System error 2148074324 has occurred"


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

↑ Back to the top


Symptoms

Consider the following scenario:
  • On a Windows Vista-based client computer, you establish a virtual private network (VPN) connection.
  • The client computer is connected to a Microsoft Windows Server 2003-based server for authentication through the VPN connection.
  • The certificate that is used for authentication does not include the Extended Key Usage (EKU) information for a smart card logon.
When you try to access shared resources through the VPN connection, you may receive the following error message:
System error 2148074324 has occurred.
The smartcard certificate used for authentication was not trusted. Please contact your system administrator.
Note This issue does not occur on a Microsoft Windows XP-based client computer.

↑ Back to the top


Cause

The issue occurs because Windows Server 2003 requires the EKU information for the smart card logon. If the certificate that is used for authentication does not include the EKU information, Windows Server 2003 denies Kerberos requests.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Note After you apply the hotfix on a computer that is running Windows Server 2003, certificates that do not include EKU information for smartcard logon are supported by Kerberos authentication.

Prerequisites

To apply this hotfix, you must have one of the following service packs installed:
  • Windows Server 2003 with Service Pack 1 (SP1)
  • Windows Server 2003 with Service Pack 2 (SP2)
Active Directory must also be installed on the server.

Restart requirement

After you apply this hotfix, you must restart the server.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Kdc
  3. Right-click Kdc, point to New, and then click DWORD Value.
  4. Type SCLogonEKUNotRequired, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Exit Registry Editor.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.2994220,16021-Aug-200706:58x86
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.4135220,16021-Aug-200707:11x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.2994614,91220-Aug-200719:01IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.4135614,91220-Aug-200719:16IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.2994419,84020-Aug-200719:00x64
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Kdcsvc.dll5.2.3790.4135419,84020-Aug-200719:18x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbpubtypekc, kbqfe, kbhotfixserver, KB936358

↑ Back to the top

Article Info
Article ID : 936358
Revision : 6
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 231