Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Volume GUIDs become invalid in Windows Server 2003 when the disk layout changes outside the context of the Virtual Disk Service and of the APIs


View products that this article applies to.

Symptoms

Consider the following scenario. In Windows Server 2003, you use a custom application that uses the Virtual Disk Service (VDS). The application changes the volume globally unique identifiers (GUIDs) outside the context of the VDS and of the APIs. The volume GUIDs are stored in the VDS cache. In this scenario, the GUIDs become invalid.

When this problem occurs, you may receive an error message that resembles the following, depending on the application that is being used:
Inconsistency between the system and Virtual Disk Service has been found due to disk signature change for disk <disk ID>
Please restart Virtual Disk Service.

↑ Back to the top


Cause

This problem occurs because of a bug in the VDS. This problem occurs when the VDS is not involved in a disk layout change or when the VDS is not notified of a disk layout change. When this problem occurs, even the Reenumerate() method and the Refresh() method do not update the cache correctly. Therefore, a call to the IVdsDisk::GetProperties() method returns the previous disk GUID, and this GUID is no longer valid. If the VDS is restarted, the volume information is updated correctly. However, if you stop the VDS while the service is in this state, the service may crash.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site: Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" section and the online request forms display the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
A 32-bit version of Windows Server 2003 with Service Pack 1 (SP1) or with Service Pack 2 (SP2)
An Itanium-based version of Windows Server 2003 with SP1 or with SP2
An x64-based version of Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vds.exe5.2.3790.2976358,91217-Jul-200711:01x86SP1SP1QFE
Vdsbas.dll5.2.3790.2976147,96818-Jul-200705:59x86SP1SP1QFE
Vdsdyndr.dll5.2.3790.2976326,14418-Jul-200706:46x86SP1SP1QFE
Vdshba_i.mofNot Applicable13,96723-Feb-200709:12Not ApplicableSP1SP1QFE
Vdshba_u.mofNot Applicable34523-Feb-200709:12Not ApplicableSP1SP1QFE
Vdsldr.exe5.2.3790.297619,45617-Jul-200711:01x86SP1SP1QFE
Vdsutil.dll5.2.3790.297661,95218-Jul-200705:59x86SP1SP1QFE
Vds_ps.dll5.2.3790.297630,72018-Jul-200705:59x86SP1SP1QFE
Vds.exe5.2.3790.4119358,91217-Jul-200713:02x86SP2SP2QFE
Vdsbas.dll5.2.3790.4119147,96818-Jul-200706:20x86SP2SP2QFE
Vdsdyndr.dll5.2.3790.4119326,65618-Jul-200706:20x86SP2SP2QFE
Vdshba_i.mofNot Applicable13,96507-Dec-200621:57Not ApplicableSP2SP2QFE
Vdshba_u.mofNot Applicable34307-Dec-200621:57Not ApplicableSP2SP2QFE
Vdsldr.exe5.2.3790.411919,45617-Jul-200713:02x86SP2SP2QFE
Vdsutil.dll5.2.3790.411961,95218-Jul-200706:20x86SP2SP2QFE
Vds_ps.dll5.2.3790.411930,72018-Jul-200706:20x86SP2SP2QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vds.exe5.2.3790.2976622,08018-Jul-200706:48x64SP1SP1QFE
Vdsbas.dll5.2.3790.2976263,68018-Jul-200706:48x64SPSP1QFE
Vdsdyndr.dll5.2.3790.2976456,19218-Jul-200706:48x64SPSP1QFE
Vdshba_i.mofNot Applicable13,96718-Jul-200706:48Not ApplicableSPSP1QFE
Vdshba_u.mofNot Applicable34518-Jul-200706:48Not ApplicableSPSP1QFE
Vdsldr.exe5.2.3790.297629,69618-Jul-200706:48x64SPSP1QFE
Vdsutil.dll5.2.3790.297694,72018-Jul-200706:48x64SPSP1QFE
Vds_ps.dll5.2.3790.297641,47218-Jul-200706:48x64SPSP1QFE
Wvds_ps.dll5.2.3790.297630,72018-Jul-200706:48x86SP1SP1QFE\WOW
Vds.exe5.2.3790.4119622,08018-Jul-200706:59x64SP2SP2QFE
Vdsbas.dll5.2.3790.4119263,68018-Jul-200706:59x64SPSP2QFE
Vdsdyndr.dll5.2.3790.4119456,70418-Jul-200706:59x64SPSP2QFE
Vdshba_i.mofNot Applicable13,96518-Jul-200706:59Not ApplicableSPSP2QFE
Vdshba_u.mofNot Applicable34318-Jul-200706:59Not ApplicableSPSP2QFE
Vdsldr.exe5.2.3790.411929,69618-Jul-200706:59x64SPSP2QFE
Vdsutil.dll5.2.3790.411994,72018-Jul-200706:59x64SPSP2QFE
Vds_ps.dll5.2.3790.411941,47218-Jul-200706:59x64SPSP2QFE
Wvds_ps.dll5.2.3790.411930,72018-Jul-200706:59x86SP2SP2QFE\WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vds.exe5.2.3790.29761,170,94418-Jul-200706:48IA-64SP1SP1QFE
Vdsbas.dll5.2.3790.2976503,80818-Jul-200706:48IA-64SPSP1QFE
Vdsdyndr.dll5.2.3790.2976766,97618-Jul-200706:48IA-64SPSP1QFE
Vdshba_i.mofNot Applicable13,96718-Jul-200706:48Not ApplicableSPSP1QFE
Vdshba_u.mofNot Applicable34518-Jul-200706:48Not ApplicableSPSP1QFE
Vdsldr.exe5.2.3790.297663,48818-Jul-200706:48IA-64SPSP1QFE
Vdsutil.dll5.2.3790.2976173,56818-Jul-200706:48IA-64SPSP1QFE
Vds_ps.dll5.2.3790.297645,56818-Jul-200706:48IA-64SPSP1QFE
Wvds_ps.dll5.2.3790.297630,72018-Jul-200706:48x86SP1SP1QFE\WOW
Vds.exe5.2.3790.41191,170,94418-Jul-200706:59IA-64SP2SP2QFE
Vdsbas.dll5.2.3790.4119503,80818-Jul-200706:59IA-64SPSP2QFE
Vdsdyndr.dll5.2.3790.4119768,51218-Jul-200706:59IA-64SPSP2QFE
Vdshba_i.mofNot Applicable13,96518-Jul-200706:59Not ApplicableSPSP2QFE
Vdshba_u.mofNot Applicable34318-Jul-200706:59Not ApplicableSPSP2QFE
Vdsldr.exe5.2.3790.411963,48818-Jul-200706:59IA-64SPSP2QFE
Vdsutil.dll5.2.3790.4119173,56818-Jul-200706:59IA-64SPSP2QFE
Vds_ps.dll5.2.3790.411945,56818-Jul-200706:59IA-64SPSP2QFE
Wvds_ps.dll5.2.3790.411930,72018-Jul-200706:59x86SP2SP2QFE\WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

↑ Back to the top


Keywords: kbautohotfix, kbbug, kbfix, kbprb, kbexpertiseadvanced, kbwinserv2003postsp2fix, kbqfe, kbhotfixserver, KB936008

↑ Back to the top

Article Info
Article ID : 936008
Revision : 5
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 399