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Event ID 3092 is logged when you try to replicate certain public folder messages from Exchange Server 2003 to Exchange Server 2007


View products that this article applies to.

Symptoms

When you try to replicate certain public folder messages from Microsoft Exchange Server 2003 to Microsoft Exchange Server 2007, the operation is unsuccessful.

Additionally, when you connect to Exchange Server 2003 to examine these messages by using the MAPI client, you notice that the date is displayed as Jan 1, 1601.

Additionally, the follow event is logged in the Application log:

Event Type: Warning
Event Source: MSExchangeIS Public Store
Event Category: Replication Errors
Event ID: 3092
Description: Error 1129 occurred while processing a replication event.
Folder: (FID) path

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Cause

This problem occurs when messages in the Exchange Server 2003 public store include date properties that are set to zero. When date properties are set to zero, the date is displayed as Jan 1, 1601 in Exchange Server 2003.

When the server that is running Exchange Server 2007 replicates the public folder that includes these messages, the replicated messages contain random data in the date properties. Therefore, Exchange Server 2007 determines that these messages are invalid, and it drops them.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 2 to be installed on the server.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services are stopped and then restarted automatically when you apply this hotfix:
  • The Microsoft Exchange Information Store service
  • The Microsoft Search service
  • The Internet Information Services (IIS) Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7653.670,14422-Jun-200717:36x86
Mdbmsg.dll6.5.7653.63,378,68822-Jun-200716:51x86
Store.exe6.5.7653.65,265,40822-Jun-200717:39x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB936000, kbhotfixserver, kbqfe, kbexpertiseinter, kbexchstore, kbautohotfix

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Article Info
Article ID : 936000
Revision : 4
Created on : 5/6/2008
Published on : 5/6/2008
Exists online : False
Views : 209