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A Windows Server 2003-based computer that uses the Storport storage driver stops responding when you try to restart or shut down the computer


View products that this article applies to.

Symptoms

A Windows Server 2003-based computer may stop responding when you try to restart it or shut it down. This problem occurs if the following conditions are true:
  • The computer is part of a storage area network (SAN).
  • The computer uses the Microsoft Storport storage driver for the QLogic QL2300 host bus adapter (HBA) driver.
Typically, this problem occurs on the following computer models:
  • HP DL380 G5
  • HP BL460C G1

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Cause

This problem may occur if you use version 5.2.3790.2723 of the Storport driver or a later version. These drivers include a change in which there is no shutdown notification for a third-party miniport driver. In this case, the third-party miniport driver cannot complete all input and output operations before the shutdown occurs.

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Resolution

To resolve this problem, follow these steps:
  1. Install Windows Server 2003 Service Pack 2 (SP2). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    889100 How to obtain the latest service pack for Windows Server 2003
  2. Apply hotfix 935561. For more information about this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
    935561 StorPort may not delete zombie LUN objects when a storage adapter is surprise-removed by software in Windows Server 2003
  3. Apply hotfix 932755. For more information about this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
    932755 An updated Storport storage driver (version 5.2.3790.4021) is available for Windows Server 2003
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbnosurvey, kbarchive, kbprb, kbtshoot, kbexpertiseinter, KB935919

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Article Info
Article ID : 935919
Revision : 4
Created on : 1/10/2015
Published on : 1/10/2015
Exists online : False
Views : 297