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Error message when you try to log on to a Telnet server that is running Windows Server 2003 with Service Pack 1 or with Service Pack 2: "Failure in initializing the telnet session"


View products that this article applies to.

Symptoms

When you try to log on to a Telnet server that is running Microsoft Windows Server 2003 with Service Pack 1 or with Service Pack 2, you receive the following error message:
Failure in initializing the telnet session. Shell process may not have been launched.
Telnet Server has closed the connection
Additionally, the following event is logged in the Application event log on the Telnet server:

Event Type: Error
Event Source: TlntSvr
Event Category: None
Event ID: 4049
User: N/A
Description:
Error in creating CMD process.
System Error: The stub received bad data.

This problem occurs if the user account that you use to log on to the Telnet server has more than 5,120 characters in the environment variables.

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Cause

This problem occurs because of a behavior in the Seclogon.dll file on the Telnet server. If the environment variables that are specified in the function contain more than 5,120 characters, the Seclogon.dll file returns an error to the CreateProcessWithTokenW function.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Seclogon.dll5.2.3790.293818,94417-May-200719:43x86
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Seclogon.dll5.2.3790.408318,43217-May-200719:04x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Seclogon.dll5.2.3790.293848,12817-May-200705:00IA-64SP1Not Applicable
Wseclogon.dll5.2.3790.293818,94417-May-200705:00x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Seclogon.dll5.2.3790.408348,12817-May-200705:05IA-64SP2Not Applicable
Wseclogon.dll5.2.3790.408318,43217-May-200705:05x86SP2WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Seclogon.dll5.2.3790.293828,16017-May-200705:00x64SP1Not Applicable
Wseclogon.dll5.2.3790.293818,94417-May-200705:00x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Seclogon.dll5.2.3790.408328,16017-May-200705:05x64SP2Not Applicable
Wseclogon.dll5.2.3790.408318,43217-May-200705:05x86SP2WOW

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Workaround

To work around this problem, limit the environment variables that are used by the user account to fewer than 5,120 characters.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

According to Microsoft Developer Network documentation, the total size of the environment block for a process cannot exceed 32,767 characters. For more information, visit the following Microsoft Web site: For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB935761

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Article Info
Article ID : 935761
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 257