Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The msDS_UserPasswordExpired attribute of a user object in an ADAM directory does not return TRUE even when the user tries to change the password on the next logon in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
On a computer that is running Microsoft Windows Server 2003, an application manages a user object in an Active Directory Application Mode (ADAM) directory.
To require the user to change the password on the next logon, the pwdLastSet attribute is set to 0.
The application uses the msDS_UserPasswordExpired attribute to determine whether the password has expired.
However, the msDS_UserPasswordExpired attribute does not return TRUE. Therefore, the next time that the user logs on to the ADAM directory, the application does not prompt the user to change the password. In this situation, the logon fails.

↑ Back to the top


Cause

This problem occurs because ADAM returns an incorrect value for the msDS_UserPasswordExpired attribute if the pwdLastSet attribute is set to 0.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site: Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" section and the online request forms display the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have the following service packs installed:
Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003
Active Directory Application Mode (ADAM) Service Pack 1

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Adamdsa.dll1.1.3790.40751,631,74407-May-200717:30x86SP2
Adamdsa.dll1.1.3790.40751,631,74407-May-200717:30x86SP2
Adamdsa.dll1.1.3790.40751,631,74407-May-200717:30x86SP2
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Adamdsa.dll1.1.3790.40752,957,31207-May-200703:11x64SP2
Adamdsa.dll1.1.3790.40752,957,31207-May-200703:11x64SP2
Adamdsa.dll1.1.3790.40752,957,31207-May-200703:11x64SP2
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Adamdsa.dll1.1.3790.29311,630,72007-May-200717:32x86SP1
Adamdsa.dll1.1.3790.29311,630,72007-May-200717:32x86SP1
Adamdsa.dll1.1.3790.29311,630,72007-May-200717:32x86SP1
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Adamdsa.dll1.1.3790.29312,955,77607-May-200703:06x64SP1
Adamdsa.dll1.1.3790.29312,955,77607-May-200703:06x64SP1
Adamdsa.dll1.1.3790.29312,955,77607-May-200703:06x64SP1

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

When this problem occurs, a trace of the network traffic resembles the following:
Status: Invalid Credentials, MatchedDN: NULL, ErrorMessage: 8009030C: LdapErr: DSID-0C090336, comment: AcceptSecurityContext error, data 773, vece
For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB935672

↑ Back to the top

Article Info
Article ID : 935672
Revision : 4
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 210