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Error message when you use Computer Management after you upgrade the computer to Windows Server 2003: "Snap-in failed to initialize"


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Symptoms

After you upgrade a computer that is running Microsoft Windows 2000 Server to Microsoft Windows Server 2003, you receive the following error message when you use Computer Management:
Snap-in failed to initialize
Name: System Information Extension
LSID:{<CLSIDNo>}
Note When you click OK to close the error message, Computer Management starts.

Additionally, when you try to use Task Scheduler, you may receive one of the following error messages:
Error 2
Could not start the Task Scheduler service on local computer.
Error 2: The system can�t find the file specified.
Error 126
Error 126: The specified module could not be found.
When this problem occurs, the following event is logged in the System log:

Event ID 7023
Source: Service Control Manager
Description: The Task Scheduler service terminated with the following error: Error description

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Cause

This problem occurs if some DLL files are missing or damaged.

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Resolution

To resolve this problem, reregister the Msinfo32.dll file, and then reregister the Schedsvc.dll file if it is required. To do this, follow these steps:
  1. Make sure that the Msinfo32.dll file is in the "C:\Program Files\Common Files\Microsoft shared\MSInfo" folder. If the Msinfo32.dll file is missing, copy the Msinfo32.dll from another computer. Then, paste it in this folder.

    Alternatively, you can use the Msinfo32.dll file that is included in hotfix 310928. For more information about this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
    310928 You cannot open an .nfo file
  2. Reregister the Msinfo32.dll file. To do this, follow these steps:
    1. Click Start, click Run, type Regsvr32 "c:\program files\common files\microsoft shared\msinfo\msinfo32.dll", and then click OK.

      Note Include the quotation marks when you type this command.
    2. When you receive a message that states that DllRegisterServer in Msinfo32.dll succeeded, click OK.
  3. Make sure that Task Scheduler works. If you still experience the problem, reregister the Schedsvc.dll file. To do this, follow these steps:
    1. Click Start, click Run, type Regsvr32 "%SystemRoot%\System32\ schedsvc.dll", and then click OK.

      Note Include the quotation marks when you type this command.
    2. When you receive a message that states that DllRegisterServer in Schedsvc.dll succeeded, click OK.

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Keywords: KB935641, kbexpertiseinter, kberrmsg, kbtshoot

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Article Info
Article ID : 935641
Revision : 2
Created on : 5/1/2007
Published on : 5/1/2007
Exists online : False
Views : 291