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A Windows XP-based portable computer cannot use the Wireless Zero Configuration service to connect to a wireless network


View products that this article applies to.

Symptoms

A Microsoft Windows XP-based portable computer cannot use the Wireless Zero Configuration service to connect to a wireless network. This behavior occurs if the following conditions are true:
  • You have an autoenrollment policy on the Windows XP-based computer.
  • The certificates expire after four weeks. The Group Policy object (GPO) sends a new certificate every three weeks.
  • The certificate is sent successfully, and you see the new certificate on the computer.
Every time that a new certificate is sent to the computer, the computer cannot connect to the wireless network. Typically, this behavior occurs with the following kinds of certificates:
  • A certificate that has the same key
  • A certificate that has a new key
  • A certificate renewal
  • A request for a new certificate
This problem may also occur on a Microsoft Windows Server 2003-based portable computer and on a Microsoft Windows 2000 Server-based portable computer.

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Cause

This problem occurs because the Wireless Zero Configuration service does not recognize the correct certificate. If you request a certificate manually or by using an autoenrollment policy, the Wireless Zero Configuration service does not obtain the correct certificate.

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Resolution

To resolve this problem, delete the archived certificates from the Certificate store. To do this, follow these steps:
  1. Start Notepad. To do this, click Start, click Run, type notepad.exe, and then click OK.
  2. Copy and then paste the following code into a new Notepad document.
    ' ' CAPICOM Constants
     
    Const CAPICOM_LOCAL_MACHINE_STORE = 1
    Const CAPICOM_CURRENT_USER_STORE = 2
    Const CAPICOM_MY_STORE = "MY"
     
    Const CAPICOM_STORE_OPEN_READ_WRITE = 1 
    Const CAPICOM_STORE_OPEN_INCLUDE_ARCHIVED = 256 
    
    
    'Set objArgs=WScript.Arguments
    'strServerName = objArgs(0)
    Dim OID
    Set OID = WScript.CreateObject("CAPICOM.OID") 
    
     
    
    '=========== capicom local machine MY store certificates ==============
    
    ' Open the store.
    Set Store = WScript.CreateObject("CAPICOM.Store")
    Store.Open CAPICOM_LOCAL_MACHINE_STORE, CAPICOM_MY_STORE, CAPICOM_STORE_OPEN_READ_WRITE  Or CAPICOM_STORE_OPEN_INCLUDE_ARCHIVED
    Set Certificates = Store.Certificates
    
    Store.Open CAPICOM_CURRENT_USER_STORE, CAPICOM_MY_STORE, CAPICOM_STORE_OPEN_READ_WRITE  Or CAPICOM_STORE_OPEN_INCLUDE_ARCHIVED
    Set Certificates = Store.Certificates
    
    For Each Certificate In Certificates
    
                    certDate = Certificate.ValidToDate
             
                    curDateTime = Date() & " " &  Time()
    
                    DIFF = DateDiff("s",curDateTime,CertDate)
                    
                    If Diff > 0 then
                                    
                    Else                               
                                    Store.Remove Certificate				
                    
                    end if
    Next Next
    
  3. Save the file as Scripts.vbs.
  4. Download the Capicom.dll file.

    The following file is available for download from the Microsoft Download Center:


    Download the Capicom.dll package now.

    For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
    119591� How to obtain Microsoft support files from online services
    Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
  5. Save the Capicom.dll file in the following folder:
    C:\WINDOWS\System32
  6. Register the Capicom.dll file, and then register the Dao360.dll file. To do this, follow these steps.
    1. Click Start, click Run, type regsvr32 capicom.dll, and then click OK.
    2. When you receive the message that the DllRegisterServer operation succeeded, click OK.
    3. Click Start, click Run, type regsvr32 c:\program files\common files\microsoft shared\dao\dao360.dll, and then click OK.
    4. When you receive the message that the DllRegisterServer operation succeeded, click OK.
  7. Double-click the Scripts.vbs file.
  8. Check the certificate store. The store must not have the archived certificates.

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Status

This behavior is by design.

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References

For more information about how to display archived certificates on a Windows XP-based computer, visit the following Microsoft Web site:

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Keywords: kbtshoot, kbbug, kbfix, kbprb, KB935432

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Article Info
Article ID : 935432
Revision : 4
Created on : 4/25/2007
Published on : 4/25/2007
Exists online : False
Views : 277