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FIX: Characters appear as question marks after you handle an input message that contains ISO 8859/1 characters when you use the Microsoft BizTalk Accelerator for HL7 1.3


View products that this article applies to.

Symptoms

When you handle an input message on a BizTalk Server 2006 computer by using the Microsoft BizTalk Accelerator for HL7 1.3, ISO 8859/1, characters in the input message appear as question marks (?). For example, you send a message that includes the following ISO 8859/1 string:
��������TestString
After the BizTalk Accelerator for HL7 1.3 disassembler (DASM) processes the message, the string resembles the following string:
????????TestString
If a map is specified in the receive port or in the send port, you may also receive the following error message:

Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5784
Date: 6/7/2007
Time: 3:49:42 PM
User: N/A
Computer: ComputerName
Description:
The Messaging Engine failed while executing the inbound map for the message coming from source URL:"C:\Labs\HL7_Inbound\*.txt" with the Message Type "MessageType". Details:"'Unicode (UTF-8)' is not a supported encoding name. Parameter name: name"

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Cause

This issue occurs because the BizTalk Accelerator for HL7 2.X receive pipeline only supports ASCII encoding. The receive pipeline does not support an ASCII character set if the ASCII character values are larger than 127. Therefore, some characters in the input message are replaced by question marks (?).

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Resolution

To resolve this problem, deploy a custom pipeline that has the encoding property set to Western European encoding. Before you build a new custom pipeline, you must install hotfix 935347. For more information about how to build the custom pipeline, see the "More information" section.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have the BizTalk Accelerator for HL7 1.3 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.solutions.btahl7.batchconstruction.dll1.3.1120.025,51216-July-20079:55x86
Microsoft.solutions.btahl7.batchorchestration.dll1.3.1120.0398,76016-July-20079:55x86
Microsoft.solutions.btahl7.hl72fasm.dll1.3.1120.062,86416-July-20079:55x86
Microsoft.solutions.btahl7.hl72fdasm.dll1.3.1120.091,54416-July-20079:55x86
Microsoft.solutions.btahl7.hl7schemas.dll1.3.1120.099,73616-July-20079:55x86
Microsoft.solutions.btahl7.pipelinecommon.dll1.3.1120.071,07216-July-20079:55x86
Microsoft.solutions.btahl7.shared.dll1.3.1120.087,44016-July-20079:55x86

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More information

After you install this hotfix, the BTAHL7 2.X receive pipeline supports the following encoding sets:
  • Western European
  • ASCII
  • UTF8
If a user selects an encoding other than ASCII, UTF8, or Western European, the following error message and information appear when the user tries to parse the message:
Input encoding is not supported.
Supported encodings are - ASCII, UTF8, Western European.
Western European encoding supports all European characters. If an input message contains some Western European characters that have ASCII values that are larger than 127, you must build a new custom pipeline.

To build a new custom pipeline, follow these steps:
  1. Open the Visual Studio 2005 IDE, and then add a new empty BizTalk Server project.
  2. Right-click the project, point to Add, and then click New Item. In the Categories list, click Pipeline Files, click Receive Pipeline, and then click OK.
  3. Drag the BTAHL7 2.X disassembler to the Disassemble area.

    Note If the BTAHL7 2. X disassembler does not appear in the Toolbox window, follow these steps:
    1. Right-click the toolbox surface, and then click Choose Items.
    2. In the window that appears, click the BizTalk Pipeline Components tab, click BTAHL7 2.X Disassembler in the Name list, and then click OK.
  4. In the Pipeline Component Properties window, select either Western-European (1252) or UTF8 (65001) in the Encoding charset list.

    Note You do not have to add ASCII encoding. ASCII is the default encoding that the HL7 receive pipeline provides. Other encoding options that appear in the Encoding charset list are not supported.
  5. Save the encoding character set that you have just created, and then deploy the project.
To resolve this problem, you can use the new custom pipeline to replace the original BTAHL7 2.X receive pipeline. To do this, use BizTalk Server Administration.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB935347, kbqfe, kbexpertiseadvanced, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 935347
Revision : 5
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 540