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A Windows Server 2003-based computer stops responding when you perform a surprise removal of an IDE device


View products that this article applies to.

Symptoms

When you perform a surprise removal of an IDE device from a Microsoft Windows Server 2003-based computer, the computer stops responding (hangs). For example, you experience this symptom after the surprise removal a CD drive from the computer.

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Cause

This problem is caused by faulty reverse integration in which the Freepdo flag is incorrectly set, and the Atapi.sys driver incorrectly processes the surprise-removal operation. In this situation, the Plug and Play component stops responding (hangs).

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Atapi.sys5.2.3790.291196,76803-Apr-200714:58x86SP1SP1QFE
Atapi.sys5.2.3790.405396,76803-Apr-200711:41x86SP2SP2QFE
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Atapi.sys5.2.3790.2911150,01603-Apr-200721:24x64SP1SP1QFE
Atapi.sys5.2.3790.4053150,01603-Apr-200721:29x64SP2SP2QFE
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Atapi.sys5.2.3790.2911311,29603-Apr-200721:23IA-64SP1SP1QFE
Atapi.sys5.2.3790.4053311,29603-Apr-200721:29IA-64SP2SP2QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB934794

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Article Info
Article ID : 934794
Revision : 7
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 243