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The Plug and Play subsystem may not detect an external storage device when it is reconnected in Windows Server 2003


View products that this article applies to.

Symptoms

If a Microsoft Windows Server 2003-based server unexpectedly loses its connection to an external storage device, the Windows Plug and Play (PnP) subsystem may not detect the device when it is reconnected. You must restart the server for it to detect the device.

Note You may experience this symptom during stress testing or when the storage system is under a heavy load.

You experience this problem if the following conditions are true:
  • The device uses the Storport.sys driver.
  • Hotfix 916048 has been applied. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    916048� You experience problems when you use the Microsoft Storport storage driver for host bus adapter removable storage on a computer that is running Windows Server 2003
  • The server has a large working set. For example, the server has a working set of approximately 1.5 gigabytes (GB).

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Cause

This problem occurs when the working set list entries (WSLE) become corrupted. When the working set list entries become corrupted, the Plug and Play subsystem may stop responding when the connection to the device is restored.

If the computer has a large working set, the WSLE may become corrupted when the computer loses its connection to the external storage device.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have one of the following operating systems installed:
  • Windows Server 2003 with Service Pack 1
  • Windows Server 2003 with Service Pack 2
  • An x64-based version of Windows Server 2003
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.29192,460,16018-Apr-200711:58Not applicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.29192,272,25618-Apr-200711:14x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.29192,312,70418-Apr-200711:13Not applicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.29192,420,73618-Apr-200711:57x86SP1SP1QFE
Ntkrnlmp.exe5.2.3790.40632,469,88818-Apr-200712:50Not applicableSP2SP2QFE
Ntkrnlpa.exe5.2.3790.40632,282,49618-Apr-200711:54x86SP2SP2QFE
Ntkrpamp.exe5.2.3790.40632,321,92018-Apr-200721:46Not applicableSP2SP2QFE
Ntoskrnl.exe5.2.3790.40632,430,46418-Apr-200712:49x86SP2SP2QFE
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hal.dll5.2.3790.2919279,04019-Apr-200704:38x64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.29194,632,06419-Apr-200704:38x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.29194,488,19219-Apr-200704:38x64SP1SP1QFE
Hal.dll5.2.3790.4063279,04019-Apr-200704:43x64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.40634,570,11219-Apr-200704:43x64SP2SP2QFE
Ntoskrnl.exe5.2.3790.40634,500,48019-Apr-200704:43x64SP2SP2QFE
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.29191,636,86419-Apr-200704:39IA-64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.29196,520,32019-Apr-200704:39IA-64SP1SP1QFE
Ntdll.dll5.2.3790.40631,636,86419-Apr-200704:43IA-64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.40636,536,70419-Apr-200704:43IA-64SP2SP2QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbwinserv2003postsp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB934739

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Article Info
Article ID : 934739
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 265