Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Auto-enrollment is not triggered when you try to use Certutil.exe on a Windows XP-based computer


View products that this article applies to.

Symptoms

When you try to use Certutil.exe on a Microsoft Windows XP-based computer, auto-enrollment is not triggered.

↑ Back to the top


Cause

This behavior occurs when you copy Certutil.exe and the supporting binaries from the following operating systems to Windows XP:
  • Windows Vista
  • Windows Server 2008
  • Windows Server 2003 Service Pack 1

↑ Back to the top


Resolution

The only version of Certutil.exe that Windows XP supports is available in the Microsoft Windows Server 2003 Administration Pack. To download the Windows Server 2003 Administration Pack, visit the following Microsoft Web site:

If you have update 907247 installed on Windows XP SP2, the version of Certutil.exe that supports the -pulse command is available in the SP1 version of the Windows Server 2003 Administration Pack. To download it, visit the following Microsoft Web site:

↑ Back to the top


More information

The output is similar to the following:
C:\>certutil -pulse 

402.203.0: 0x80070057 (WIN32: 87): ..

CertCli Version 307.5584.0: 0x80070002 (WIN32: 2) 

CertUtil: -pulse 

command FAILED: 0x80070002 (WIN32: 2) 

CertUtil: The system cannot find the file specified. 301.3160.0: 0x80070002 (WIN32: 2) 

↑ Back to the top


Keywords: kbcertservices, kbexpertiseinter, kbexpertiseadvanced, kbtshoot, kbprb, KB934576

↑ Back to the top

Article Info
Article ID : 934576
Revision : 5
Created on : 12/1/2007
Published on : 12/1/2007
Exists online : False
Views : 479