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The functionality that you expect from a callout .dll file does not work as expected in Microsoft Dynamics CRM


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

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Symptoms

After you create a callout .dll file and then modify the Callout.config.xml file, the functionality that you expect from the callout .dll file does not work as expected in Microsoft Dynamics CRM.

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Cause

This issue may occur if one or more of the following conditions are true:
  • The callout .dll file and the Callout.config.xml file are not located in the following folder:
    C:\Program Files\Microsoft CRM\Server\bin\assembly
  • You did not reset Microsoft Internet Information Services (IIS) after you modified the Callout.config.xml file.
  • The account that is running the CRMAppPool application pool does not have permissions for the following folder:
    C:\Program Files\Microsoft CRM\Server\bin\assembly
  • The SetupMode registry subkey is set to 1.

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Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, follow these steps:
  1. Move the callout .dll file and the Callout.config.xml file to the following folder:
    C:\Program Files\Microsoft CRM\Server\bin\assembly
  2. Reset IIS. To do this, click Start, click Run, type iisreset in the Open box, and then click OK.

    Note You should reset IIS after hours because users will temporarily lose connectivity to Microsoft Dynamics CRM.
  3. Grant the account that is running the CRMAppPool application pool the Full Control permission for the following folder:
    C:\Program Files\Microsoft CRM\Server\bin\assembly
    To do this, follow these steps:
    1. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
    2. Expand the server name.
    3. Expand Application Pools.
    4. Right-click CRMAppPool, and then click Properties.
    5. Click the Identity tab.
    6. Identify the security account for the CRMAppPool application pool.
    7. In Windows Explorer, right-click the following folder and then click Sharing and Security:
      C:\Program Files\Microsoft CRM\Server\bin\assembly
    8. Click the Security tab.
    9. Click the account that you identified in step f, click the Allow check box for the Full Control permission, and then click OK.
  4. Change the SetupMode registry subkey to 0. To do this, follow these steps:
    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then select the following registry subkey:
      HKEY_LOCAL_MACHINE\Software\Microsoft\MSCRM
    3. After you select the registry subkey, right-click SetupMode, and then click Modify.
    4. In the Value data box, type 0, and then click OK.
    5. On the File menu, click Exit.
    6. Restart the Microsoft Dynamics CRM server.

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More information

If the callout .dll file encounters a problem, an error message is logged in the Application log. To view the Application log, click Start, point to All Programs, point to Administrative Tools, and then click Event Viewer. Double-click Application.

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Keywords: KB933842, kbprb, kbmbsmigrate, kbmbscustomization, kbtshoot, kbmbscrm40

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Article Info
Article ID : 933842
Revision : 5
Created on : 8/15/2007
Published on : 8/15/2007
Exists online : False
Views : 417