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FIX: Error message when you use the ADsSecurityUtility object in VBScript code on a Windows Server 2003-based computer: "Permission denied"


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

On a Microsoft Windows Server 2003-based computer, when you use the ADsSecurityUtility object to write a security descriptor back to a registry key in VBScript code, you receive the following error message:
Script: ScriptName
Line: LineNumber
Char: CharacterNumber
Error: Permission denied
Code: 800A0046
Source: Microsoft VBScript runtime error

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Cause

This problem occurs because the ADsSecurityUtility object does not open the registry key by using the appropriate credentials.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 installed before you apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit editions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Activeds.dll5.2.3790.2894198,65605-Mar-200717:55x86SP1SP1QFE
Activeds.dll5.2.3790.4035200,19205-Mar-200718:10x86SP2SP2QFE
Windows Server 2003, 64-bit editions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Activeds.dll5.2.3790.2894356,86405-Mar-200716:39x64SP1SP1QFE
Wactiveds.dll5.2.3790.2894198,65605-Mar-200716:39x86SP1WOW
Activeds.dll5.2.3790.4035356,86405-Mar-200716:44x64SP2SP2QFE
Wactiveds.dll5.2.3790.4035200,19205-Mar-200716:44x86SP2WOW
Windows Server 2003, Itanium-based editions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Activeds.dll5.2.3790.2894594,94405-Mar-200716:39IA-64SP1SP1QFE
Wactiveds.dll5.2.3790.2894198,65605-Mar-200716:39x86SP1WOW
Activeds.dll5.2.3790.4035594,94405-Mar-200716:44IA-64SP2SP2QFE
Wactiveds.dll5.2.3790.4035200,19205-Mar-200716:44x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003postsp2fix, kbcode, kberrmsg, kbfix, kbbug, kbhotfixserver, kbqfe, kbpubtypekc, KB933789

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Article Info
Article ID : 933789
Revision : 7
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 248