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When you log on to a Windows Server 2003 Service Pack 1-based terminal server from a client computer that is running a Japanese version of Windows XP, the keyboard layout on the terminal server differs from the IME keyboard layout on the client computer


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry

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Symptoms

Consider the following scenario:
  • You log on to a remote Microsoft Windows Server 2003 Service Pack 1 (SP1)-based terminal server from a client computer that is running a Japanese version of Microsoft Windows XP.
  • The terminal server uses a Microsoft Global Input Method Editor (IME) keyboard layout.
In this scenario, the keyboard layout on the terminal server differs from the IME keyboard layout on the client computer.

This problem occurs even though the following hotfix is applied on the terminal server:
917910� The terminal server IME keyboard layout differs from the client computer when you remotely log on to a Windows Server 2003 Service Pack 1-based terminal server

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Cause

When the client computer connects to the terminal server, the client computer reads IME file information from the following registry entry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client\IME Mapping Table\JPN\imjp81.ime
If the imjp81.ime registry entry contains a value, the client computer sends the value to the terminal server. However, the imjp81.ime registry entry uses a default value of "null." The client computer incorrectly assumes that "null" is a valid file name.

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Resolution

To resolve this problem, apply this hotfix on each client computer.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The Japanese version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mstscax.dll5.1.2600.3113655,87205-Apr-200714:50x86

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Workaround

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, follow these steps on each client computer:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Terminal Server Client\IME Mapping Table\JPN
  3. Right-click the imjp81.ime entry, and then click Modify.
  4. Clear the Value data text box, and then click OK.
  5. Exit Registry Editor.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinxppresp3fix, kbexpertisebeginner, kbexpertiseinter, kbbug, kbfix, kbHotfixServer, kbqfe, KB933737

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Article Info
Article ID : 933737
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 380