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The Wmiprvse.exe process stops responding on a domain controller that is running Windows Server 2003


View products that this article applies to.

Symptoms

On a domain controller that is running Microsoft Windows Server 2003, you may experience the following symptoms:
  • The computer runs slowly.
  • The Wmiprvse.exe process uses 100 percent of the CPU resources. The process stops responding.
  • The domain controller delays authenticating requests that are sent by client computers. Or, domain controllers cannot authenticate the requests.
This problem occurs if a Windows Management Instrumentation (WMI) query that is running on the domain controller includes the following clause:
Select * from Win32_Account where LocalAccount=True and SIDType=1

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Cause

This problem occurs because the WMI module does not correctly process the clause that is mentioned in the "Symptoms" section. Instead, an infinite loop occurs.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the following conditions must be true:
  • The computer is a domain controller.
  • Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 in installed. For more information about how to obtain the latest service pack, click the following article number to view the article in the Microsoft Knowledge Base:
    889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll5.2.3790.40321,372,67228-Feb-200718:59x86
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll5.2.3790.40322,352,12828-Feb-200703:43x64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll5.2.3790.40325,042,17628-Feb-200703:43IA-64
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll5.2.3790.28911,372,67228-Feb-200719:04x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll5.2.3790.28912,352,12828-Feb-200703:40x64
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll5.2.3790.28915,041,66428-Feb-200703:40IA-64

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Workaround

To work around this problem, do not include the clause that is mentioned in the "Symptoms" section in a WMI query on a domain controller.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB933593

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Article Info
Article ID : 933593
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 248