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Web services such as Exchange ActiveSync or Outlook Web Access unexpectedly stop working after an automatic hotfix installation


View products that this article applies to.

Symptoms

Consider the following scenario. You configure Exchange ActiveSync (EAS) on a Microsoft Exchange Server 2003 computer. On the same Exchange computer, you also configure automatic hotfix installation. For example, you configure automatic hotfix installation that uses the Windows Update service. In this scenario, after a hotfix is automatically installed, users may report that Web services such as Exchange ActiveSync or Outlook Web Access are unavailable.

Note This problem can also occur when you manually install a hotfix that is configured to automatically stop and restart the World Wide Web Publishing Service (WWW service).

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Cause

This problem occurs because the hotfix installer does not restart the WWW service after the hotfix is installed.

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Workaround

To work around this problem, you must monitor all services on the Exchange computer that is running EAS and that is configured for automatic hotfix installation. You must use the most suitable method in your environment to trigger a warning if the WWW service remains stopped for a period that is longer than a preconfigured threshold. Then you must manually intervene or programmatically intervene to restart the service.

Note The Exchange System Manager provides basic options that you can use to monitor services and trigger messages and warnings. For more information, see Exchange Online Help, or click the following article number to view the article in the Microsoft Knowledge Base:
310315 Troubleshooting monitoring and status in Exchange and in Small Business Server
More specific monitoring and alerting capabilities are offered by Microsoft Operations Manager (MOM). For example, you can configure MOM to trigger alerts based on specific events or based on changes in the status of a service.

For more information about how to monitor Windows services by using MOM, visit the following Microsoft Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The time limit for the graceful shutdown of the WWW service is 90 seconds. When EAS is loaded and a mobile client synchronizes with the Exchange computer at least one time by using Exchange ActiveSync Direct Push Technology (Direct Push), the time to shut down the WWW service is affected. The WWW service cannot be shut down on this computer within the default time limit. In this scenario, an attempt to shut down the WWW service may cause the service to be forcefully shut down.

For example, if you try to manually shut down the WWW service, you receive the following event in the System log:

Event No: 1013
Event Type: Warning
Event Source: W3SVC
Description: A process serving application pool 'ExchangeApplicationPool' exceeded time limits during shut down. The process id was 'ID_Number'.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Additionally, by the time this warning is logged, the WWW service is forcefully shut down.

Hotfix installer action

If a hotfix installer tries to stop the WWW service at the beginning of a hotfix installation and the service is not shut down gracefully, the installer may not try to restart the WWW service.

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Keywords: KB933359, kbprb, kbtshoot, kbexpertiseadvanced, kbservice, kbautoupdate, kbwindowsupdate

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Article Info
Article ID : 933359
Revision : 4
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 398