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Error message when you try to track an HTML-formatted e-mail message that contains an image in the signature in Microsoft Dynamics CRM 3.0: "An error occurred promoting this item to Microsoft CRM"


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Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

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Symptoms

Symptom 1

Consider the following scenario. In Microsoft Dynamics CRM 3.0, you try to track an HTML-formatted e-mail message. The e-mail message contains an image in the signature. If you use Microsoft Office Word as your e-mail editor or if you use Word to read Rich Text Format e-mail messages, you receive the following error message:
An error occurred promoting this item to Microsoft CRM. The Microsoft CRM Server could not be contacted or the user has insufficient permissions to perform this action. This item has been saved to Microsoft Outlook but is not being tracked in Microsoft CRM.

Symptom 2

Consider the following scenario. You try to promote an e-mail message in HTML format from the Microsoft Dynamics CRM client for Microsoft Office Outlook. The e-mail message contains an embedded picture. In some cases, the embedded picture is missing. For example, an X is displayed. In this scenario, you receive the following error message after you click Track In CRM:
An error occurred promoting this item to Microsoft CRM. The Microsoft CRM server could not be contacted or the user has insufficient permissions to perform this action. Do you want to send the e-mail? If you click Yes, the e-mail will be sent out, but no corresponding activity will be created in Microsoft CRM.

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Cause

Cause 1

This issue may occur if one of the following conditions is true:
  • The forms cache in Microsoft Outlook is corrupted.
  • The Microsoft Outlook temporary folder contains too many files. By design, Outlook has a limitation of 99 duplicated names that can be saved to the same image. Therefore, Outlook cannot read the embedded image when you have more than 100 e-mail messages with the same image.

Cause 2

Microsoft Office Outlook saves embedded images in a subfolder under the "Temporary Internet Files" folder in the following location:
C:\Documents and Settings\<User Account>\Local Settings\Temporary Internet Files
Outlook limits the number of the temporary files to 100, and Outlook numbers these files as 0 through 99. If the limit is reached, embedded images are not displayed. Therefore, the Microsoft Dynamics CRM client for Outlook cannot fetch and store the embedded images in a Microsoft Dynamics CRM database.

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Resolution

Resolution 1

To resolve this issue, use one of the following methods.

Method 1: Clear the forms cache in Outlook

  1. On the Tools menu, click Options.
  2. Click the Other tab.
  3. Click Advanced Options.
  4. Click Custom Forms.
  5. Click Manage Forms.
  6. Click Clear Cache, and then click Close.
  7. Click OK to close the Options dialog box.
  8. Click OK to close the Advanced Options dialog box.
  9. Click OK to close the Options dialog box.
  10. Restart Outlook.

Method 2: Delete the files in the OutlookSecureTempFolder location

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Exit all Microsoft Office programs.
  2. Click Start, click Run, type regedit in the Open box, and then click OK.
  3. Locate and then select the registry key that corresponds to your version of Microsoft Outlook:
    • HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Security
    • HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Outlook\Security
    • HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Security
  4. Right-click OutlookSecureTempFolder, and then click Modify.
  5. Right-click the location in the Value data box, and then click Copy.
  6. In the Edit String dialog box, click Cancel.
  7. On the File menu, click Exit.
  8. Start Windows Explorer.
  9. Paste the location that you copied in step 5 into the Address box in Windows Explorer, and then press ENTER.
  10. Make sure that the location that you specified in step 5 is selected, and then click Select All on the Edit menu.
  11. On the File menu, click Delete. Click Yes to confirm the deletion.
  12. Start Microsoft Outlook.

Resolution 2

Delete all the files and all the subfolders under the following folder:
C:\Documents and Settings\<User Account>\Local Settings\Temporary Internet Files
For more information about the temporary folder that Outlook uses, click the following article number to view the article in the Microsoft Knowledge Base:
296115� Opened attachments are saved in a subdirectory in your Temporary Internet Files directory

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More information

If you continue to experience the problem that is mentioned in the "Symptoms" section, view the following Microsoft Knowledge Base (KB) article:
925532� Error message when you track a Rich Text Format e-mail message in Microsoft Dynamics CRM client for Outlook: "An error occurred promoting this item to Microsoft CRM"

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Keywords: KB933234, kbprb, kbmbsmigrate, kberrmsg, kbmbsemail, kbtshoot, kbmbscrm40no

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Article Info
Article ID : 933234
Revision : 3
Created on : 3/19/2008
Published on : 3/19/2008
Exists online : False
Views : 340