Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Web page is blank in Internet Explorer 7


View products that this article applies to.

Symptoms

When you open a Web page in Windows Internet Explorer 7, the page is blank. However, if you refresh the Web page, its contents may appear.

Note: If you are seeing this article because Internet Explorer displays a Blank webpage when browsing websites, and the resolution steps in this article do not resolve this issue, see the following help topic for troubleshooting steps:

Why do some webpages look incorrect in Internet Explorer 9?

↑ Back to the top


Cause

This problem may occur when either of the following conditions is true:
  • The Web page uses the <SCRIPT> tag.
  • The Web page uses multibyte character set (MBCS) characters. For example, the Web page contains Japanese characters.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfixes and security updates that are included in SP2 for Windows Vista Service and for Windows Server 2008

For more information about the hotfixes and the security updates that are included in SP2 for Windows Vista and for Windows Server 2008, visit the following Microsoft TechNet Web site: -Note: Currently, the list of hotfixes and security updates is available only in English.

Security update information

To resolve this problem, install the most current cumulative security update for Internet Explorer. To install the most current updates, visit the following Microsoft Web site: For more technical information about the most current cumulative security update for Internet Explorer, visit the following Microsoft Web site: Note This fix was first included in security update 933566 (MS07-033). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
933566 MS07-033: Cumulative Security Update for Internet Explorer
A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 7 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Internet Explorer 7 on 32-bit versions of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll7.0.6000.205443,582,97624-Feb-200702:56x86
Mshtml.tlb7.0.6000.205441,383,42424-Feb-200700:34Not Applicable
Internet Explorer 7 on 64-bit versions of Windows Vista
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll7.0.6000.205445,667,84024-Feb-200704:17x64
Mshtml.tlb7.0.6000.205441,383,42424-Feb-200700:34Not Applicable
Internet Explorer 7 on Windows XP with Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll7.0.6000.205443,582,97628-Feb-200716:13x86
Internet Explorer 7 on x86-based versions of Windows Server 2003 with Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll7.0.6000.205443,582,97605-Apr-200700:54x86
Internet Explorer 7 on x64-based versions of Windows Server 2003 with Service Pack 2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mshtml.dll7.0.6000.205445,667,84004-Apr-200715:01x64SP2Not Applicable
Wmshtml.dll7.0.6000.205443,582,97604-Apr-200715:02x86SP2WOW
Internet Explorer 7 on Itanium-based versions of Windows Server 2003 with Service Pack 2
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mshtml.dll7.0.6000.205449,974,78404-Apr-200714:05IA-64SP2Not Applicable
Wmshtml.dll7.0.6000.205443,582,97604-Apr-200714:05x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB933006, atdownload, kbqfe, kbbug, kbhotfixserver, kbvistasp1fix

↑ Back to the top

Article Info
Article ID : 933006
Revision : 7
Created on : 12/26/2012
Published on : 12/26/2012
Exists online : False
Views : 387