Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Stop error message on a Windows Server 2003 R2-based computer that has Subsystem for UNIX-based Applications installed: "000000C2"


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003 R2-based computer that has Subsystem for UNIX-based Applications installed, you receive the following Stop error message:
Bugcheck code 000000C2 (Parameter1, Parameter2, Parameter3, Parameter4)
BAD_POOL_CALLER (c2)
Then, the computer restarts automatically.

↑ Back to the top


Cause

This problem occurs because the behavior occurs:
  • The POSIX subsystem driver allocates fast mutexes from an incorrect memory pool.
  • A race condition occurs. The POSIX subsystem driver begins to clean up an ionode when handles to the ionode are still open.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Subsystem for UNIX-based Applications installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Psxdrv.sys9.0.3790.29017,29616-Mar-200711:14Not ApplicableSP1SP1QFE
Windows Server 2003 R2 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Psxdrv.sys9.0.3790.40427,29616-Mar-200713:36Not ApplicableSP2SP2QFE
Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Psxdrv.sys9.0.3790.29018,19216-Mar-200723:55x64SP1SP1QFE
Windows Server 2003 R2 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Psxdrv.sys9.0.3790.40428,19216-Mar-200723:56x64SP2SP2QFE
Windows Services for UNIX 3.5
File nameFile versionFile sizeDateTimePlatform
Psxdrv.sys8.0.1969.6311,71203-Oct-200806:11x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kberrmsg, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix, KB932701

↑ Back to the top

Article Info
Article ID : 932701
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 264