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A printer driver upgrade operation may fail in Windows Server 2003


View products that this article applies to.

Symptoms

When you try to upgrade the printer driver on a computer that is running Microsoft Windows Server 2003, the upgrade operation may fail.

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Cause

This problem occurs because the Print Spooler service uses an incorrect character to end the values of some REG_MULTI_SZ registry entries. Therefore, when the application that upgrades the printer driver reads data from these registry entries, an error occurs.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit (x86-based) versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4089342,01628-May-200717:14x86
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4087750,08028-May-200715:06x64
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4089968,19228-May-200715:06IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The values of REG_MULTI_SZ registry entries must end with a double Unicode NULL (00 00 00 00). Otherwise, registry functions cannot find the correct ending character. For more information, visit the following Microsoft Web site: For more information about the structure that contains printer driver information, visit the following Microsoft Web site:For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB932699

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Article Info
Article ID : 932699
Revision : 7
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 226