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A Windows Server 2003-based computer stops responding when an application frequently schedules threads


View products that this article applies to.

Symptoms

A Microsoft Windows Server 2003-based computer stops responding when an application frequently schedules threads. This problem usually occurs if the application repeatedly uses one or more of the following functions:
  • SetThreadAffinityMask
  • SetThreadIdealProcessor
  • SetProcessAffinityMask

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Cause

This problem occurs because of a synchronization issue in the thread scheduling code. If an application changes the affinity of a thread while the system is using the affinity, the affinity may not be synchronized correctly. This situation may cause an endless loop to occur.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.29272,463,23230-Apr-200711:44Not ApplicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.29272,275,32830-Apr-200710:58x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.29272,315,77630-Apr-200705:24Not ApplicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.29272,423,29630-Apr-200711:44x86SP1SP1QFE
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.40712,491,90430-Apr-200716:51Not ApplicableSP2SP2QFE
Ntkrnlpa.exe5.2.3790.40712,304,00030-Apr-200715:52x86SP2SP2QFE
Ntkrpamp.exe5.2.3790.40712,343,93630-Apr-200715:51Not ApplicableSP2SP2QFE
Ntoskrnl.exe5.2.3790.40712,451,96830-Apr-200716:51x86SP2SP2QFE
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.29271,636,86430-Apr-200715:54IA-64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.29276,524,41630-Apr-200715:54IA-64SP1SP1QFE
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.40711,636,86430-Apr-200716:05IA-64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.40716,559,23230-Apr-200716:05IA-64SP2SP2QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hal.dll5.2.3790.2927280,06430-Apr-200715:54x64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.29274,635,13630-Apr-200715:54x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.29274,490,24030-Apr-200715:54x64SP1SP1QFE
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hal.dll5.2.3790.4071280,06430-Apr-200716:03x64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.40714,591,10430-Apr-200716:03x64SP2SP2QFE
Ntoskrnl.exe5.2.3790.40714,521,98430-Apr-200716:04x64SP2SP2QFE

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Workaround

To work around this problem, disable the application that frequently schedules the threads.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the SetThreadAffinityMask function, visit the following Microsoft Developer Network Web site:For more information about the SetThreadIdealProcessor function, visit the following Microsoft Developer Network Web site:For more information about the SetProcessAffinityMask function, visit the following Microsoft Developer Network Web site: For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB932375

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Article Info
Article ID : 932375
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 232