Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A memory leak occurs on an Exchange 2003 server, and the server becomes unresponsive after it runs for several days


View products that this article applies to.

Symptoms

Consider the following scenario. On a server that is running Microsoft Exchange Server 2003, you set the value of the RestrictionMethod registry entry to 2 to configure flat group restrictions on a connector. Then, you send many e-mail messages through the connector. The Exchange 2003 server runs for several days. When you view the Epoxy Bytes Allocated\DSAccess performance counter, you notice that the number of items increases. However, the number of items never decreases. The server finally becomes unresponsive and must be restarted. Additionally, the following event is logged:

Event ID: 9582
Event Type: Error
Event Source: MSExchangeIS
Event Category: Performance
Description: The virtual memory necessary to run your Exchange server is fragmented in such a way that normal operation may begin to fail. It is highly recommended that you restart all Exchange services to correct this issue.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
895407� In Exchange Server 2003, message delivery to local mailboxes and to external mailboxes is slower than you expect after you configure delivery restrictions based on distribution groups

↑ Back to the top


Cause

This problem occurs because of a memory leak on the Exchange 2003 server.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Microsoft Exchange 2003 Service Pack 2 (SP2) must be installed before you apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Drviis.dll6.5.7652.17135,16805-Mar-200718:44
Exsmtp.dll6.5.7652.17406,52805-Mar-200703:14
Gwart.dll6.5.7652.1766,56005-Mar-200717:42
Phatcat.dll6.5.7652.17493,56805-Mar-200718:41
Reapi.dll6.5.7652.17840,19205-Mar-200719:14

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange Server software updates, click the following article number to view the article in the Microsoft Knowledge Base:
817903� New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB932182, kbqfe, kbhotfixserver, kbexpertiseinter, kbexchstore, kbautohotfix

↑ Back to the top

Article Info
Article ID : 932182
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 233