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Two taskbars are displayed, or the Language bar is displayed two or more times on the taskbar, on a computer that is running Windows Server 2003 or Windows XP


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP, two or more users are logging on to a computer by using non-console terminal sessions. In this case, the users may experience one of the following symptoms:
  • Two taskbars are displayed.
  • The Language bar is displayed two or more times on the taskbar.
When this problem occurs, you cannot correctly view the applications that are running by using the taskbar.

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Cause

The cause is a timing problem in the Explorer.exe processes.

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Resolution

Hotfix information

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows Server 2003 with Service Pack 1 (SP1) or Windows Server 2003 with Service Pack 2 (SP2) installed on the computer.
Restart requirement
You have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Explorer.exe6.0.3790.28751,050,62405-Feb-200710:57x86
Windows Server 2003 SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Explorer.exe6.0.3790.40161,053,18405-Feb-200714:36x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Explorer.exe6.0.3790.28751,364,48005-Feb-200715:34x64SP1Not Applicable
Wexplorer.exe6.0.3790.28751,050,62405-Feb-200715:34x86SP1WOW
Windows Server 2003 SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Explorer.exe6.0.3790.40161,364,48005-Feb-200716:03x64SP2Not Applicable
Wexplorer.exe6.0.3790.40161,053,18405-Feb-200716:03x86SP2WOW
Windows Server 2003 SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Explorer.exe6.0.3790.28751,716,22405-Feb-200715:34IA-64SP1Not Applicable
Wexplorer.exe6.0.3790.28751,050,62405-Feb-200715:34x86SP1WOW
Windows Server 2003 SP2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Explorer.exe6.0.3790.40161,716,22405-Feb-200716:03IA-64SP2Not Applicable
Wexplorer.exe6.0.3790.40161,053,18405-Feb-200716:03x86SP2WOW

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows XP with Service Pack 2 (SP2) installed on the computer.
Restart requirement
You have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP SP2
File nameFile versionFile sizeDateTimePlatform
Explorer.exe6.0.2900.31111,033,21602-Apr-200712:01x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbexpertiseinter, kbhotfixserver, kbqfe, KB932039

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Article Info
Article ID : 932039
Revision : 5
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 265