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WMI returns a NULL value for the ProviderName attribute of the Win32_MappedLogicalDisk WMI class in Windows Server 2003


View products that this article applies to.

Symptoms

In Microsoft Windows Server 2003, when you use the Win32_MappedLogicalDisk Windows Management Instrumentation (WMI) class to query information about a mapped drive, WMI returns a NULL value for the ProviderName attribute. Therefore, you cannot retrieve the path information for the mapped drive.

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Cause

This problem occurs if the following conditions are true:
  • You use the Win32_MappedLogicalDisk WMI class in a Terminal Server session.
  • The Terminal Server session is not a console session.
  • The drive that you query is mapped to a Distributed File System (DFS) shared folder.
In this scenario, the IoGetRequestorSessionId function returns an incorrect session ID to the DFS client.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.2891100,35228-Feb-200710:24x86
Windows Server 2003 with SP2, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.4032103,42428-Feb-200715:44x86
Windows Server 2003 with SP1, Itanium-based versions
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File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.2891311,80828-Feb-200715:08IA-64
Windows Server 2003 with SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.4032311,80828-Feb-200715:13IA-64
Windows Server 2003, x64-based versions
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File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.2891179,71228-Feb-200715:07x64
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mup.sys5.2.3790.4032179,71228-Feb-200715:09x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003postsp2fix, kbexpertiseinter, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB931953

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Article Info
Article ID : 931953
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 237