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The Exchange System Attendant Service generates offline address book files continually, and Event IDs 1031 and 1032 are logged in Exchange Server 2003


View products that this article applies to.

Symptoms

In Microsoft Exchange Server 2003, the Exchange System Attendant Service generates offline address book files continually. The service does this instead of using the Heoabupdate.exe tool to generate new offline address book files one time per day.

Additionally, the following events are logged in the Application log:


Event Type: Error
Event Source: MSExchangeSA
Event Category: General
Event ID: 1031
Description: One of the System Attendant's task is blocked. Function: COffLineABScanTask::Work
For more information, click http://www.microsoft.com/contentredirect.asp.


Event Type: Information
Event Source: MSExchangeSA
Event Category: General
Event ID: 1032
Description: One of the System Attendant's task has recovered from a long delay. Function: COffLineABScanTask::Work
For more information, click http://www.microsoft.com/contentredirect.asp.

CAUSE

This problem occurs when the Microsoft Solution for Hosted Messaging and Collaboration deployment tool sets an incorrect registry value.

By default, Microsoft Solution for Hosted Messaging and Collaboration 3.5 and Microsoft Solution for Hosted Messaging and Collaboration 3.0 run the Heoabupdate.exe tool to generate new offline address book files one time per day.

Additionally, the tool sets a registry value to make sure that the Exchange System Attendant Service generates the offline address book files according to the schedule of the Exchange System Attendant Service.

However, if this registry value is set incorrectly, the Exchange System Attendant Service generates offline address book files continually.

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Resolution

To resolve this issue, set the following registry key on all servers that are hosting the offline address book files:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeSA\Parameters\Disable OABScanTask
To do this, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeSA\Parameters\Disable OABScanTask
  3. Locate the DisableOABScanTask registry entry.
  4. Right-click DisableOABScanTask, and then click Rename.
  5. Type Disable OABScanTask, and then press ENTER.

    Important Make sure that there is a space character between "Disable" and "OABScanTask."
  6. Right-click Disable OABScanTask, and then click Modify.
  7. In the Edit DWORD Value dialog box, click Decimal under Base.
  8. In the Value data box, type 1, and then click OK.
  9. Close Registry Editor.
Note When you set the "Disable OABScanTask" registry value to 1, you disable the OABScan task. If you want to enable the OABScan task, set the "Disable OABScanTask" value to 0 (zero). Alternatively, remove the "Disable OABScanTask" registry value.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB931904, kbprb, kbtshoot, kbexpertiseinter

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Article Info
Article ID : 931904
Revision : 4
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 298